View Issue Details

IDProjectCategoryView StatusLast Update
0002609mantisbtemailpublic2014-12-08 00:33
ReportervboctorAssigned Tograngeway 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0002609: Support multiple valid e-mail domains.
Description

Allow $g_limit_email_domain to be a single domain or an array of allowed domains. For example:

$g_limit_email_domain = 'mydomain.com';
$g_limit_email_domain = array('mydomain.com', 'mydomain.net', 'mydomain.net');

Should both be valid.

TagsNo tags attached.

Relationships

has duplicate 0005385 closedthraxisp Let admin set a list of valid domains for new email addresses 
has duplicate 0013960 closedatrol g_limit_email_domain should accept multiple domains 

Activities

jfitzell

jfitzell

2002-10-15 15:18

reporter   ~0003365

Good idea though it will require a bit of work. You can't just append the correct domain anymore, you actually have to provide a list box of valid domains and let the user choose one.

Not opposed at all, just pointing out some issues involved.

I'd love the patch the version on SF to allow SF email addresses so I can start getting emails from this bloody thing again... (not sure if the patch could be easily made to work with 0.17.5 though)

fman

fman

2004-11-23 07:59

reporter   ~0008411

  1. I think it's not a good solution have a variable that can have two types
    i.e. can be a string or an array. Better approach use allways an array.

  2. I can't understant this piece of code:

    Only allow and send email to addresses in the given domain

    For example:

    $g_limit_email_domain = 'users.sourceforge.net';

    $g_limit_email_domain = OFF;

What is a valid range for $g_limit_email_domain ?
I dislike OFF,ON and a valid domainname, because ON /OFF (IMO) means boolean
variable. Again why not use g_limit_email_domain="" to say OFF ???

Best Regards

Francisco

mikewhit

mikewhit

2005-02-18 11:58

reporter   ~0009336

Surely this should be by domain names (regexps ?) in a database table,
rather than having to hack code ?

It only needs to filter email addresses at signup, or whenever the Admin
changes the valid list in Manage Users.

Perhaps a Protected (admin) account could be exempt from this.

If it worked like *nix host name permissions, there could be three lists:
1) explicit list (no pattern matching) of allowed email addresses - this would allow only selected users to join up
2) "domain allow" - users matching the domain names in this list would also be allowed to sign up
3) "domain deny" - users matching the names in this list would be explicitly prevented from signing up

This then gives the possibility to restrict access to explicit users by using 1) and then not allowing anyone else.

monotek

monotek

2010-11-19 09:36

reporter   ~0027424

Any news about this?

grangeway

grangeway

2014-09-22 15:46

reporter   ~0041278

Resolved in 1.3

Related Changesets

MantisBT: master d5870f80

2014-01-06 17:46:19

Paul Richards

Details Diff
limit_email_domains: Allow users to be locked to a choice of multiple email domains, instead of a single domain. For example:

$g_limit_email_domains = array( 'users.sourceforge.net', 'sourceforge.net' );

would allow people to sign up using email address @users.sourceforge.net or @sourceforge.net only
mod - account_update.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/email_api.php Diff File
mod - core/obsolete.php Diff File
mod - core/print_api.php Diff File
mod - lost_pwd.php Diff File
mod - manage_user_create.php Diff File
mod - manage_user_update.php Diff File
mod - signup.php Diff File

Issue History

Date Modified Username Field Change
2004-11-23 07:59 fman Note Added: 0008411
2005-02-18 11:58 mikewhit Note Added: 0009336
2005-03-24 20:16 thraxisp Relationship added has duplicate 0005385
2010-11-19 09:36 monotek Note Added: 0027424
2012-02-28 02:26 atrol Relationship added has duplicate 0013960
2014-09-22 15:46 grangeway Changeset attached => MantisBT master d5870f80
2014-09-22 15:46 grangeway Note Added: 0041278
2014-09-22 15:46 grangeway Status acknowledged => resolved
2014-09-22 15:46 grangeway Fixed in Version => 1.3.0-beta.1
2014-09-22 15:46 grangeway Resolution open => fixed
2014-09-22 15:46 grangeway Assigned To => grangeway
2014-09-25 17:26 atrol Target Version => 1.3.0-beta.1
2014-12-08 00:33 vboctor Status resolved => closed