View Issue Details

IDProjectCategoryView StatusLast Update
0023650mantisbtapi restpublic2017-12-04 02:17
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.8.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0023650: Leverage If-Match when deleting issues
Description

If If-Match is specified with an etag and it doesn't match the issue etag or the issue doesn't exist, then return 412 Precondition Failed, otherwise delete.

This makes sure that the client DELETE fails if the issue doesn't exist or exists but has been modified since issue was retrieved by the client.

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master 4aec7f9a

2017-11-18 02:17:30

vboctor

Details Diff
Leverage If-None-Match when deleting issues

If client attempts to delete an issue that doesn’t exist or that was modified since issue was retrieved,
then fail with error `412 Precondition failed`.

Fixes 0023650
mod - api/rest/restcore/issues_rest.php Diff File
mod - core/constant_inc.php Diff File

MantisBT: master c3729274

2017-11-19 03:34:49

vboctor

Details Diff
Update hash calculation for deletion of issues

Base calculation of hash for etag on output of get issues and compare with provided `If-None-Match`.

Fixes 0023650
mod - api/rest/restcore/issues_rest.php Diff File

Issue History

Date Modified Username Field Change
2017-11-18 02:16 vboctor New Issue
2017-11-18 02:16 vboctor Status new => assigned
2017-11-18 02:16 vboctor Assigned To => vboctor
2017-11-18 03:03 vboctor Note Added: 0058222
2017-11-24 19:26 vboctor Changeset attached => MantisBT master 4aec7f9a
2017-11-24 19:26 vboctor Changeset attached => MantisBT master c3729274
2017-11-24 19:26 vboctor Status assigned => resolved
2017-11-24 19:26 vboctor Resolution open => fixed
2017-11-24 19:26 vboctor Fixed in Version => 2.9.0
2017-11-27 21:21 vboctor Summary Leverage If-None-Match when deleting issues => Leverage If-Match when deleting issues
2017-11-27 21:21 vboctor Description Updated View Revisions
2017-12-04 02:17 vboctor Status resolved => closed