View Issue Details

IDProjectCategoryView StatusLast Update
0023342mantisbtadministrationpublic2017-09-23 13:19
Reporterbhumika.khatriAssigned Toatrol 
PriorityhighSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version2.5.1 
Target VersionFixed in Version 
Summary0023342: Permission management issue
Description

I have created one developer user and created 2 issues with this user that is not assigned to any user for Project A. same way i have created one developer user and created 2 issues with this user that is not assigned to any user for Project A.
Now i have logged in with UserA but i am able to see 4 issues for Project A. I need functionality that user can see only created and assigned own issues.
Please help me to sort out this issue.

TagsNo tags attached.

Relationships

duplicate of 0010831 acknowledged how can I allow user to view only the issue that assigned to them 

Activities

atrol

atrol

2017-09-12 04:42

developer   ~0057693

You can limit reporters to access issues that they have reported, check option limit_reporters for it.
Viewing also assigned issues is not possible at the moment, see 0010831 for it,

bhumika.khatri

bhumika.khatri

2017-09-12 05:25

reporter   ~0057695

i have gone through above issue, but it dont work for permission management. Developer user can see the issues that is created or assigned to him.

bhumika.khatri

bhumika.khatri

2017-09-12 05:25

reporter   ~0057696

i have gone through above issue, but it dont work for permission management. Developer user can see the issues that is created or assigned to him.

atrol

atrol

2017-09-12 16:29

developer   ~0057704

Please don't reopen, unless there is a bug or a feature request which is not covered by 0010831.

Issue History

Date Modified Username Field Change
2017-09-11 11:22 bhumika.khatri New Issue
2017-09-12 04:42 atrol Assigned To => atrol
2017-09-12 04:42 atrol Status new => resolved
2017-09-12 04:42 atrol Resolution open => fixed
2017-09-12 04:42 atrol Note Added: 0057693
2017-09-12 04:42 atrol Relationship added related to 0010831
2017-09-12 04:42 atrol Severity major => feature
2017-09-12 05:25 bhumika.khatri Note Added: 0057695
2017-09-12 05:25 bhumika.khatri Status resolved => feedback
2017-09-12 05:25 bhumika.khatri Resolution fixed => reopened
2017-09-12 05:25 bhumika.khatri Note Added: 0057696
2017-09-12 16:29 atrol Status feedback => resolved
2017-09-12 16:29 atrol Resolution reopened => duplicate
2017-09-12 16:29 atrol Note Added: 0057704
2017-09-12 16:29 atrol Relationship replaced duplicate of 0010831
2017-09-23 13:19 atrol Status resolved => closed