View Issue Details

IDProjectCategoryView StatusLast Update
0023341mantisbtotherpublic2017-09-25 17:08
Reporterhelfy022Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionno change required 
Product Version2.5.1 
Target VersionFixed in Version 
Summary0023341: inferring the current category
Description

Hello,

The following custom function statement will set to the variable "$t_project_name" the current project that has been selected:

$t_project_name = project_get_name( helper_get_current_project() );

Is there a similar helper function available to set to a variable the current category that has been chosen (in particular, when the user is on the report issue page)?

Thanks,
Ryan.

TagsNo tags attached.

Activities

atrol

atrol

2017-09-12 04:29

developer   ~0057691

in particular, when the user is on the report issue page

The category is not known to PHP (the server) as long as you are on the report page.
It's known to PHP after you submitted the report.
You have to use JavaScript (on client side) if you want to access the the chosen category while you are on the report page.

helfy022,

This is not a bug or feature request for MantisBT (you are asking for help on how to writing extensions for MantisBT). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

helfy022

helfy022

2017-09-15 10:12

reporter   ~0057727

Hi Atrol,

Thanks very much for the feedback.

Please feel free to close this issue.

Ryan.

Issue History

Date Modified Username Field Change
2017-09-11 10:42 helfy022 New Issue
2017-09-12 04:29 atrol Assigned To => atrol
2017-09-12 04:29 atrol Status new => resolved
2017-09-12 04:29 atrol Resolution open => no change required
2017-09-12 04:29 atrol Note Added: 0057691
2017-09-15 10:12 helfy022 Note Added: 0057727
2017-09-25 17:08 atrol Status resolved => closed