View Issue Details

IDProjectCategoryView StatusLast Update
0022984mantisbtuipublic2017-09-03 18:41
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.6.0Fixed in Version2.6.0 
Summary0022984: Calendar doesn't show the correct date the first time it opens
Description

When opening the date/time picker widget on a field with an existing date, the calendar shows the current date instead of the date in the field.

After clicking on the calendar icon a second time, the widget displays the correct date

See attached screenshots for illustration

TagsNo tags attached.

Relationships

related to 0020040 closedsyncguru Replace jscalendar by a newer widget 

Activities

dregad

dregad

2017-06-08 20:17

developer  

Selection_002.png (14,275 bytes)
Selection_002.png (14,275 bytes)
Selection_001.png (14,422 bytes)
Selection_001.png (14,422 bytes)
dregad

dregad

2017-06-08 20:30

developer   ~0057047

Looks like a bug in the bootstrap-datetimepicker library

Several issues have been logged upstream, e.g.

We are currently using version 4.17.42 (even though it's labeled 4.17.43). There's a release 4.17.47 available, need to test if it fixes the issue.

Related Changesets

MantisBT: master 608189de

2017-06-09 13:03:29

dregad

Details Diff
Update bootstrap-datetimepicker to 4.17.47

When opening the date/time picker widget on a field with an existing
date, the calendar showed the current date instead of the one in the
field. After clicking on the calendar icon a second time, the widget
displays the correct date.

Fixes 0022984
mod - core/constant_inc.php Diff File
rm - css/bootstrap-datetimepicker-4.17.43.min.css Diff File
add - css/bootstrap-datetimepicker-4.17.47.min.css Diff File
rm - js/bootstrap-datetimepicker-4.17.43.min.js Diff File
add - js/bootstrap-datetimepicker-4.17.47.min.js Diff File
mod - library/README.md Diff File

Issue History

Date Modified Username Field Change
2017-06-08 20:17 dregad New Issue
2017-06-08 20:17 dregad File Added: Selection_001.png
2017-06-08 20:17 dregad File Added: Selection_002.png
2017-06-08 20:25 dregad Relationship added related to 0020040
2017-06-08 20:30 dregad Status new => confirmed
2017-06-08 20:30 dregad Product Version => 2.0.0
2017-06-08 20:30 dregad Target Version => 2.6.0
2017-06-08 20:30 dregad Note Added: 0057047
2017-06-09 13:01 dregad Summary Calendar doesn't show the correct date the first time it open => Calendar doesn't show the correct date the first time it opens
2017-06-28 09:24 dregad Changeset attached => MantisBT master 608189de
2017-06-28 09:24 dregad Assigned To => dregad
2017-06-28 09:24 dregad Status confirmed => resolved
2017-06-28 09:24 dregad Resolution open => fixed
2017-06-28 09:24 dregad Fixed in Version => 2.6.0
2017-09-03 18:41 vboctor Status resolved => closed