View Issue Details

IDProjectCategoryView StatusLast Update
0022811mantisbtupgradepublic2017-05-21 03:41
ReporterblankrabbitAssigned Todregad 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0022811: useing Source Control Integration 2.0.0 update error
Description

used mantisbt-2.2.1
add Source Control Intergration 2.0.0 plugin base MantisBT Core 2.0.0
then need to Upgrade

bug Upgrade error

APPLICATION ERROR #2503
Upgrading the plugin schema failed in block 0000012

TagsNo tags attached.

Relationships

duplicate of 0020168 closeddregad Use of 'mantis' as plugin table prefix prevents plugin's installation 

Activities

dregad

dregad

2017-04-25 06:41

developer   ~0056705

used mantisbt-2.2.1

You should update to 2.2.4 or later, see 0022690

Source Control Intergration 2.0.0

Update to 2.0.2, see https://github.com/mantisbt-plugins/source-integration/issues/205

Upgrading the plugin schema failed in block 0000012

It is not clear from your report, whether this is a new installation, or an upgrade from an earlier MantisBT / Source Integration plugin version. If so, please specify the old versions used.

Also, check that the Mantis database user account has sufficient privileges, see 0013137

blankrabbit

blankrabbit

2017-04-25 22:11

reporter   ~0056712

Source Control Intergration version is OK , it's seem mantisbt-2.2.1 not support this plugin .

for already used mantisbt-2.2.1 for all company , I hate to upgrade the wrong version ,so I want to know which version can support the plugin?

thanks !



新建位图图像.bmp (1,998,438 bytes)
dregad

dregad

2017-04-26 03:02

developer   ~0056716

You did not answer my questions in 0022811:0056705 .

I hate to upgrade the wrong version ,so I want to know which version can support the plugin?

The plugin works with all 2.x versions AFAIK.

The reason I recommended to upgrade Mantis is not related to a problem with the plugin, but due to the fact that there is a critical security vulnerability in 2.2.1.

You may want to set $g_show_detailed_errors = ON in your _configinc.php file, try to upgrade the plugin again and save the resulting error page with detailed errors (as HTML file). If that doesn't help you to fix the problem, post the file here, but be careful to edit any sensitive information out.

atrol

atrol

2017-05-07 10:42

developer   ~0056794

blankrabbit,

You did not provide any feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

blankrabbit

blankrabbit

2017-05-09 07:43

reporter   ~0056816

used VMware Workstation create the same system as online system.

I found the plugin works can with empty 2.2.1 versions ( create only and not used by users ) .

And I am set $g_show_detailed_errors = ON get the detail message .

please check it . thanks;

blankrabbit

blankrabbit

2017-05-09 07:49

reporter   ~0056817

Last edited: 2017-05-09 10:18

View 2 revisions

this is error message

EDIT [dregad]: see 0022811:0056821 for the attachment

dregad

dregad

2017-05-09 10:11

developer   ~0056820

This is a duplicate of https://github.com/mantisbt-plugins/source-integration/issues/212 and will be fixed by 0020168

Please make sure that your $g_db_table_plugin_prefix is not equal to mantis.

dregad

dregad

2017-05-09 10:16

developer   ~0056821

For the record, this is the original error message from 0022811:0056817, without the unnecessary overhead of javascript and css files.



error_message_22811.html (36,579 bytes)
blankrabbit

blankrabbit

2017-05-09 23:03

reporter   ~0056822

set $g_db_table_plugin_prefix ='' or $g_db_table_plugin_prefix ='mt' have new error message

APPLICATION ERROR #2503
Upgrading the plugin schema failed in block #14.

It's seem mantis_Source_repository_mantis not create before update ?



MantisBT-block14(prefix is null).html (37,240 bytes)
blankrabbit

blankrabbit

2017-05-09 23:04

reporter   ~0056823

please check it again , thanks!

dregad

dregad

2017-05-10 03:23

developer   ~0056824

Make sure the tables in your database match the new prefix.

blankrabbit

blankrabbit

2017-05-10 04:25

reporter   ~0056825

don't understand what's mean.

first init mantis system $g_db_table_plugin_prefix value is 'mantis' , now I reset it to ' ' , then what shall I do with the table in database?

dregad

dregad

2017-05-10 05:29

developer   ~0056826

what shall I do with the table in database

If you previously installed plugins with $g_db_table_plugin_prefix = 'mantis'; then you will have tables in your DB that are named like mantis_mantis_<plugin name>_<table name>_table, e.g. mantis_mantis_Source_repository_table

You need to manually rename those tables to match the new values for the prefix, using SQL statements or your favorite DB admin tool, e.g. mantis_plugin_Source_repository_table.

For the record, I don't recommend setting $g_db_table_plugin_prefix to null.

Issue History

Date Modified Username Field Change
2017-04-24 22:32 blankrabbit New Issue
2017-04-25 06:41 dregad Status new => feedback
2017-04-25 06:41 dregad Note Added: 0056705
2017-04-25 22:11 blankrabbit File Added: 新建位图图像.bmp
2017-04-25 22:11 blankrabbit Note Added: 0056712
2017-04-25 22:11 blankrabbit Status feedback => new
2017-04-26 03:02 dregad Status new => feedback
2017-04-26 03:02 dregad Note Added: 0056716
2017-05-07 10:42 atrol Assigned To => dregad
2017-05-07 10:42 atrol Status feedback => resolved
2017-05-07 10:42 atrol Resolution open => no change required
2017-05-07 10:42 atrol Note Added: 0056794
2017-05-09 07:43 blankrabbit Status resolved => feedback
2017-05-09 07:43 blankrabbit Resolution no change required => reopened
2017-05-09 07:43 blankrabbit Note Added: 0056816
2017-05-09 07:49 blankrabbit File Added: error message.rar
2017-05-09 07:49 blankrabbit Note Added: 0056817
2017-05-09 07:49 blankrabbit Status feedback => assigned
2017-05-09 10:11 dregad Status assigned => resolved
2017-05-09 10:11 dregad Resolution reopened => duplicate
2017-05-09 10:11 dregad Note Added: 0056820
2017-05-09 10:11 dregad Relationship added duplicate of 0020168
2017-05-09 10:16 dregad File Added: error_message_22811.html
2017-05-09 10:16 dregad Note Added: 0056821
2017-05-09 10:17 dregad File Deleted: error message.rar
2017-05-09 10:18 dregad Note Edited: 0056817 View Revisions
2017-05-09 23:03 blankrabbit File Added: MantisBT-block14(prefix is null).html
2017-05-09 23:03 blankrabbit Note Added: 0056822
2017-05-09 23:04 blankrabbit Status resolved => feedback
2017-05-09 23:04 blankrabbit Resolution duplicate => reopened
2017-05-09 23:04 blankrabbit Note Added: 0056823
2017-05-10 03:23 dregad Status feedback => resolved
2017-05-10 03:23 dregad Resolution reopened => duplicate
2017-05-10 03:23 dregad Note Added: 0056824
2017-05-10 04:25 blankrabbit Note Added: 0056825
2017-05-10 05:29 dregad Note Added: 0056826
2017-05-21 03:41 atrol Status resolved => closed