View Issue Details

IDProjectCategoryView StatusLast Update
0022363mantisbtrelationshipspublic2017-02-26 21:17
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1.0 
Target Version2.2.0Fixed in Version2.2.0 
Summary0022363: Setting a duplicate id should update relationship with target issue if already exists
Description

At the moment, an error is prompted rather than updating the relationship type to duplicate of. For example, 'related' can become 'duplicate of'.

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master 1516e6e9

2017-02-11 21:23:17

vboctor

Details Diff
Duplicate id updates relationship if exists

If a relationship exists between issue being updated with a duplicate id, and the duplicate issue,
update it to reflect duplicate relationship type rather than erroring out.

Fixes 0022363
mod - bug_update.php Diff File
mod - core/constant_inc.php Diff File
mod - lang/strings_english.txt Diff File

Issue History

Date Modified Username Field Change
2017-02-11 21:19 vboctor New Issue
2017-02-11 21:19 vboctor Status new => assigned
2017-02-11 21:19 vboctor Assigned To => vboctor
2017-02-12 19:00 vboctor Note Added: 0055654
2017-02-19 20:01 vboctor Changeset attached => MantisBT master 1516e6e9
2017-02-19 20:01 vboctor Status assigned => resolved
2017-02-19 20:01 vboctor Resolution open => fixed
2017-02-19 20:01 vboctor Fixed in Version => 2.2.0
2017-02-19 20:22 vboctor Target Version => 2.2.0
2017-02-26 21:17 vboctor Status resolved => closed