View Issue Details

IDProjectCategoryView StatusLast Update
0022264mantisbtattachmentspublic2017-02-07 17:26
ReporternoizegAssigned Toatrol 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version2.0.0 
Target VersionFixed in Version 
Summary0022264: APPLICATION ERROR 0000401 while moving issue with attachments to different project
Description

If you try to move issue with attachments from one project to another project with different upload folder, you'll get situation where issue itself won't be moved, but physical attachments will be.

Moving issues works if both projects have default upload folder ( because in that case db_query won't be called inside file_move_bug_attachments --- if( $t_path_from == $t_path_to ) {return;} )

Steps To Reproduce

1.Use DISK upload method.

  1. Create "TEST1" project with default path
  2. Create "TEST2" project with custom upload folder
  3. Make sure custom folder is writable to mantis
  4. Report an issue to "TEST1" project.
  5. Attach at least one file to newly created issue.
  6. Open this issue and press Move button.
  7. Select project "TEST2" and confirm.
  8. You will see APPLICATION ERROR 0000401.
  9. Issue won't be moved from "TEST1" project.
  10. Open this issue and you'll see "Attachment missing" error.
  11. Go to "TEST2" upload folder and check that physical files where moved there.
TagsNo tags attached.

Relationships

duplicate of 0021994 closeddregad issue with attachments cannot be moved between projects with different upload directories (uploads saved in file system) 

Activities

noizeg

noizeg

2017-01-26 14:22

reporter  

2017-01-26 22.02.44.png (124,489 bytes)
2017-01-26 22.02.44.png (124,489 bytes)

Issue History

Date Modified Username Field Change
2017-01-26 14:22 noizeg New Issue
2017-01-26 14:22 noizeg File Added: 2017-01-26 22.02.44.png
2017-01-26 16:56 atrol Assigned To => atrol
2017-01-26 16:56 atrol Status new => resolved
2017-01-26 16:56 atrol Resolution open => duplicate
2017-01-26 16:56 atrol Relationship added duplicate of 0021994
2017-02-07 17:26 atrol Status resolved => closed