View Issue Details

IDProjectCategoryView StatusLast Update
0022221mantisbtdocumentationpublic2017-01-31 04:02
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version2.1.0Fixed in Version2.1.0 
Summary0022221: Documentation: update 'Database tables' section
Description

Since the introduction of db_get_table() and removal of database table name config options, the 'Database Table Variables' section is mostly empty, containing only the table prefix and suffix. Since these configuration are related to database settings, it makes sense to merge it into the 'Database' section.

Moreover, only the $g_db_table_prefix is currently documented; $g_db_table_suffix and $g_db_table_plugin_prefix are missing.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 03a36d97

2017-01-18 06:39:54

dregad

Details Diff
Documentation: review Database Tables section

- Add missing entry for $g_db_table_suffix
- Add missing entry for $g_db_table_plugin_prefix
- Add warning about identifier size (Oracle 30-char limit)
- Remove obsolete information
- Rewording

Fixes 0022221
mod - docbook/Admin_Guide/en-US/config/database.xml Diff File

MantisBT: master 99fd9e29

2017-01-18 06:49:46

dregad

Details Diff
Review PHPDoc for table prefix/suffix

Fixes 0022221
mod - config_defaults_inc.php Diff File

MantisBT: master 74699db9

2017-01-18 08:08:38

dregad

Details Diff
Config+Doc: Move 'Database Tables' section to 'Database'

Since the introduction of db_get_table() and removal of database table
name config options, the 'Database Table Variables' section is mostly
empty, containing only the table prefix and suffix. Since these
configuration are related to database settings, it makes sense to merge
the 2 sections.

$g_db_table_prefix, $g_db_table_suffix and $g_db_table_plugin_prefix
configs are now defined under the 'Database Settings' section in
config_defaults_inc.php.

Fixes 0022221
mod - config_defaults_inc.php Diff File
mod - docbook/Admin_Guide/en-US/Configuration.xml Diff File
mod - docbook/Admin_Guide/en-US/config/database.xml Diff File
rm - docbook/Admin_Guide/en-US/config/tables.xml Diff File

Issue History

Date Modified Username Field Change
2017-01-18 09:42 dregad New Issue
2017-01-18 09:42 dregad Status new => assigned
2017-01-18 09:42 dregad Assigned To => dregad
2017-01-18 09:44 dregad Changeset attached => MantisBT master 74699db9
2017-01-18 09:44 dregad Changeset attached => MantisBT master 03a36d97
2017-01-18 09:44 dregad Changeset attached => MantisBT master 99fd9e29
2017-01-18 09:44 dregad Status assigned => resolved
2017-01-18 09:44 dregad Resolution open => fixed
2017-01-18 09:44 dregad Fixed in Version => 2.1.0
2017-01-31 04:02 vboctor Status resolved => closed