View Issue Details

IDProjectCategoryView StatusLast Update
0022204mantisbtmarkdownpublic2017-01-31 04:02
ReporterbadfilesAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.1.0Fixed in Version2.1.0 
Summary0022204: News headlines are parsed with markdown, though they should not be
Description

Markdown ON:

<h4 class="widget-title lighter">
                <i class="ace-icon fa fa-edit"></i>
                <p>Test headline</p>            </h4>

Markdown OFF:

<h4 class="widget-title lighter">
                <i class="ace-icon fa fa-edit"></i>
                Test headline           </h4>
TagsNo tags attached.

Relationships

child of 0022180 new Markdown issues following implementation in 0017920 

Activities

dregad

dregad

2017-01-20 09:54

developer   ~0055241

@joel see attached screenshot (from main_page.php, with $g_news_enabled = ON) for illustration of what this issue is about.



main_no_markdown.png (2,369 bytes)
main_no_markdown.png (2,369 bytes)
main_with_markdown.png (2,581 bytes)
main_with_markdown.png (2,581 bytes)
joel

joel

2017-01-20 22:17

developer   ~0055246

Last edited: 2017-01-21 01:42

View 4 revisions

Thanks @dregad, I think its because headlines is being process with the text Mantis Core Formatting plugin, since Markdown is part of it.

 $t_headline = string_display_links( $p_headline );

solution: (remove the string_display_links helper)

$t_headline =  $p_headline;
joel

joel

2017-01-21 01:38

developer   ~0055247

Last edited: 2017-01-21 01:41

View 5 revisions

We can do it by tweaking the css as well without altering the code.

#news-items p { margin: 0 0 10px; all: inherit; }
joel

joel

2017-01-21 02:29

developer   ~0055248

Last edited: 2017-01-21 02:30

View 2 revisions

Ok, here is the PR for this issue https://github.com/mantisbt/mantisbt/pull/1003

Related Changesets

MantisBT: master f1aaddfb

2017-01-22 18:01:01

vboctor

Details Diff
Markdown: Fix broken layout in news page

Fixes 0022204
mod - core/print_api.php Diff File

Issue History

Date Modified Username Field Change
2017-01-15 16:37 badfiles New Issue
2017-01-15 18:09 dregad Relationship added child of 0022180
2017-01-20 09:54 dregad File Added: main_no_markdown.png
2017-01-20 09:54 dregad File Added: main_with_markdown.png
2017-01-20 09:54 dregad Note Added: 0055241
2017-01-20 22:17 joel Note Added: 0055246
2017-01-20 22:23 joel Note Edited: 0055246 View Revisions
2017-01-21 01:38 joel Note Added: 0055247
2017-01-21 01:39 joel Note Edited: 0055247 View Revisions
2017-01-21 01:40 joel Note Edited: 0055247 View Revisions
2017-01-21 01:40 joel Note Edited: 0055247 View Revisions
2017-01-21 01:41 joel Note Edited: 0055247 View Revisions
2017-01-21 01:42 joel Note Edited: 0055246 View Revisions
2017-01-21 01:42 joel Note Edited: 0055246 View Revisions
2017-01-21 02:29 joel Note Added: 0055248
2017-01-21 02:30 joel Note Edited: 0055248 View Revisions
2017-01-22 18:01 vboctor Changeset attached => MantisBT master f1aaddfb
2017-01-22 18:01 vboctor Assigned To => vboctor
2017-01-22 18:01 vboctor Status new => resolved
2017-01-22 18:01 vboctor Resolution open => fixed
2017-01-22 18:01 vboctor Fixed in Version => 2.1.0
2017-01-23 03:17 dregad Target Version => 2.1.0
2017-01-31 04:02 vboctor Status resolved => closed