View Issue Details

IDProjectCategoryView StatusLast Update
0022158mantisbttime trackingpublic2017-09-03 18:41
ReporterdevzingAssigned Tocproensa 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.5 
Target Version2.6.0Fixed in Version2.6.0 
Summary0022158: Time tracking report excludes issues with no category assigned
Description

When reporting time tracking the query is requiring a category be assigned to the bug even though there is an option to not require a category ($g_allow_no_category)

Steps To Reproduce

set $g_allow_no_category = ON
create an issue and don't assign a category
create an issue and do assign a category
add a note with time tracking to each issue
run the time tracking report
only the note associate to the issue with a category is reported.

TagsNo tags attached.

Relationships

related to 0020783 closedcommunity Add category field to time tracking csv/Excel exports 

Activities

atrol

atrol

2017-01-10 15:13

developer   ~0055035

One of those nice filter issues.
@cproensa maybe you could have a look at it. Seems to be a problem in dealing with FILTER_PROPERTY_CATEGORY_ID if no category is set.

cproensa

cproensa

2017-08-19 06:30

developer   ~0057505

@cproensa maybe you could have a look at it. Seems to be a problem in dealing with FILTER_PROPERTY_CATEGORY_ID if no category is set.

No, it's a specific query built in the timetracking report page

cproensa

cproensa

2017-08-19 06:34

developer   ~0057506

Can you try the fix added here?
PR https://github.com/mantisbt/mantisbt/pull/1158

I don't use timetracking, so can't test well for it.

Related Changesets

MantisBT: master a152d85b

2017-08-19 06:31:12

cproensa


Committer: dregad Details Diff
Fix timetracking report with no category

Don't require a category to be assigned to the bug as there is an option
to not require a category ($g_allow_no_category)

Fixes: 0022158
mod - core/billing_api.php Diff File

Issue History

Date Modified Username Field Change
2017-01-10 13:22 devzing New Issue
2017-01-10 15:13 atrol Status new => confirmed
2017-01-10 15:13 atrol Note Added: 0055035
2017-08-19 06:30 cproensa Note Added: 0057505
2017-08-19 06:34 cproensa Assigned To => cproensa
2017-08-19 06:34 cproensa Status confirmed => feedback
2017-08-19 06:34 cproensa Note Added: 0057506
2017-08-20 14:59 atrol Relationship added related to 0020783
2017-08-21 04:14 dregad Changeset attached => MantisBT master a152d85b
2017-08-21 04:14 cproensa Status feedback => resolved
2017-08-21 04:14 cproensa Resolution open => fixed
2017-08-21 04:14 cproensa Fixed in Version => 2.6.0
2017-08-21 04:55 atrol Target Version => 2.6.0
2017-09-03 18:41 vboctor Status resolved => closed