View Issue Details

IDProjectCategoryView StatusLast Update
0022074mantisbttaggingpublic2016-12-30 15:54
ReporteratrolAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.4 
Target Version1.3.5Fixed in Version1.3.5 
Summary0022074: System notice when detaching tags
Description

Regression in 1.3.4

Get
SYSTEM NOTICE: 'Undefined index: user_id' in '/var/www/html/master-1.3.x/core/tag_api.php' line 828
when detaching a tag which has not been attached by yourself

Additional Information

Caused by changes in function tag_bug_get_row where parameter $p_tag_id is no longer used.

TagsNo tags attached.

Relationships

related to 0021914 closedcproensa tags column in view-all page issues one query for each bug row 

Activities

cproensa

cproensa

2016-12-26 13:57

developer   ~0054830

PR: https://github.com/mantisbt/mantisbt/pull/981

Thanks for the finding...

Related Changesets

MantisBT: master-1.3.x b59807e6

2016-12-26 13:49:48

cproensa

Details Diff
Fix regression for function tag_bug_get_row()

Fix regression caused by changes in function tag_bug_get_row() where parameter
$p_tag_id is no longer used.
The modified function was returning an array of all tag rows for the bug_id,
instead of a single tag row, if it exists.

Fixes: 0022074
mod - core/tag_api.php Diff File

Issue History

Date Modified Username Field Change
2016-12-26 11:35 atrol New Issue
2016-12-26 11:36 atrol Relationship added related to 0021914
2016-12-26 11:40 atrol Assigned To => cproensa
2016-12-26 11:40 atrol Status new => assigned
2016-12-26 11:40 atrol Additional Information Updated View Revisions
2016-12-26 11:40 atrol Target Version => 1.3.5
2016-12-26 13:57 cproensa Note Added: 0054830
2016-12-27 11:53 cproensa Changeset attached => MantisBT master-1.3.x b59807e6
2016-12-27 11:53 cproensa Status assigned => resolved
2016-12-27 11:53 cproensa Resolution open => fixed
2016-12-27 11:53 cproensa Fixed in Version => 1.3.5
2016-12-30 15:54 vboctor Status resolved => closed