View Issue Details

IDProjectCategoryView StatusLast Update
0022031mantisbtrsspublic2017-01-30 09:48
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.4 
Target Version1.3.5Fixed in Version1.3.5 
Summary0022031: RSS throws a system notice
Description

When using any RSS link

SYSTEM NOTICE: 'Only variables should be passed by reference' in '/...../library/rssbuilder/class.RSSBuilder.inc.php' line 52

TagsNo tags attached.

Relationships

related to 0020372 closeddregad Inline error reports should not mess up non-HTML output 

Activities

cproensa

cproensa

2016-12-11 10:54

developer   ~0054727

Last edited: 2016-12-11 10:55

View 2 revisions

I have opted for disabling inline error for RSS

Some warnings may be issued due to php strict settings and/or newer versions, as this library is quite old.

https://github.com/mantisbt/mantisbt/pull/975

dregad

dregad

2017-01-30 09:48

developer   ~0055396

Commit MantisBT master 078444f4 message had a typo in referenced issue ID, it should have been Fixes 0022131

Related Changesets

MantisBT: master-1.3.x e992a0a7

2016-12-11 10:52:24

cproensa


Committer: vboctor Details Diff
Prevent inline error in RSS output

Disable inline error reporting to not mess with RSS output.

Fixes: 0022031
mod - issues_rss.php Diff File

Issue History

Date Modified Username Field Change
2016-12-11 09:34 cproensa New Issue
2016-12-11 10:54 cproensa Assigned To => cproensa
2016-12-11 10:54 cproensa Status new => assigned
2016-12-11 10:54 cproensa Note Added: 0054727
2016-12-11 10:55 cproensa Note Edited: 0054727 View Revisions
2016-12-11 12:34 dregad Relationship added related to 0020372
2016-12-11 23:10 vboctor Changeset attached => MantisBT master-1.3.x e992a0a7
2016-12-11 23:10 vboctor Assigned To cproensa => vboctor
2016-12-11 23:10 vboctor Status assigned => resolved
2016-12-11 23:10 vboctor Resolution open => fixed
2016-12-11 23:10 vboctor Fixed in Version => 1.3.5
2016-12-12 01:22 vboctor Assigned To vboctor => cproensa
2016-12-12 01:49 atrol Target Version => 1.3.5
2016-12-30 15:54 vboctor Status resolved => closed
2017-01-30 09:04 dregad Changeset attached => MantisBT master 078444f4
2017-01-30 09:45 dregad Changeset removed MantisBT master 078444f4 =>
2017-01-30 09:48 dregad Note Added: 0055396