View Issue Details

IDProjectCategoryView StatusLast Update
0021798mantisbtprintingpublic2017-03-08 05:19
ReportermboutellAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version1.3.1 
Target Version1.3.6Fixed in Version1.3.6 
Summary0021798: Print reports failed : special characters are not formatted
Description

When printing reports in word format, special characters like "é" or "à" are replaced by symbols.
Moreover, my issues doesn't contain "Resolution" field and in the reports this field is replaced by "@5@".

Is there any solution ? This issue appears after migrating from 1.2.17 to 1.3.1

TagsNo tags attached.

Relationships

has duplicate 0022103 closedatrol export a ticket in word format - Problems with german Umlaut 
has duplicate 0022498 closedatrol "Print Reports" for issues from View Issues page doesn't handle Chinese characters 

Activities

dregad

dregad

2016-10-13 03:59

developer   ~0054214

Could you please clarify the problem, providing steps to reproduce and screenshots to illustrate the issues you're facing ?

mboutell

mboutell

2016-10-14 03:53

reporter  

GFS.docx (15,594 bytes)
mboutell

mboutell

2016-10-14 03:56

reporter   ~0054218

Please find in attachment an example (The resolution should be empty, and the fields contains symbols)

Steps to reproduce :
Create an issue with summary or description or note containing "é" or "à" characters.

dregad

dregad

2016-10-14 04:47

developer   ~0054219

Thanks for the feedback.

Resolution: @5@

'5' is not a standard resolution code [1], can you please ensure you've followed the guidelines for customizing enumerations [2] and provide the relevant configuration settings if the problem persists.

[1] https://github.com/mantisbt/mantisbt/blob/release-1.3.1/config_defaults_inc.php#L3343
[2] https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.customize.enums

Regarding accented characters, it looks like an ANSI<=>UTF-8 encoding issue. Not sure whether this is caused by MantisBT code or local setup. I don't have time to look into it right now.

atrol

atrol

2016-10-14 04:55

developer   ~0054220

Resolution: @5@

I assume mboutell forgot to copy his custom_* files from his old 1.2.17 version to the config folder of the new 1.3.1 installation.

Not sure whether this is caused by MantisBT code
It seems not.
The special character in description of 0021798 look fine when exporting as .doc and opening the file in Libre Office.

mboutell

mboutell

2016-10-14 05:03

reporter   ~0054221

@atrol : sorry but the custom_* files are in the "config" folder... I didn't set any enumeration for resolution field...

atrol

atrol

2016-10-14 05:14

developer   ~0054222

I didn't set any enumeration for resolution field...

I am quite sure you did.
As pointed out by dregad, there is no resolution 5 in standard Mantis.

Do you set $g_resolution_enum_string in config_inc.php?
If not, you may have set it before, created issues with this setting and removed the setting after that.

mboutell

mboutell

2016-10-14 05:22

reporter   ~0054223

$g_resolution_enum_string = '10:open,20:fixed,30:reopened,40:unable to duplicate,50:not fixable,60:duplicate,70:not a bug,80:suspended,90:wont fix';

It's the only existing line in my files.
I've hidden "resolution" field it's not possible to create an issue and setting the resolution. In revision of my issue there is no information about resolution...

atrol

atrol

2016-10-14 07:49

developer   ~0054224

Last edited: 2016-10-14 07:53

View 2 revisions

Check database table mantis_bug_table for entries where resolution is 5

Did you set $g_default_bug_resolution ?

atrol

atrol

2016-10-25 01:25

developer   ~0054331

mboutell,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

mboutell

mboutell

2016-10-26 02:38

reporter   ~0054346

My corrupted file is in attachment, I still have the encoding problem.
The problem about "@5@" was another problem.
Could you please tell me what can I do ?
I just open issue with characters as "é" or "à" and then export.

atroladmin

atroladmin

2016-10-26 02:49

administrator   ~0054347

Run admin/check/index.php
Do you get any warnings for UTF-8?

If so, this is what dregad wrote 0021798:0054219

Regarding accented characters, it looks like an ANSI<=>UTF-8 encoding issue.

mboutell

mboutell

2016-10-26 02:54

reporter   ~0054348

No there is no warnings for UTF-8

atrol

atrol

2016-11-01 10:34

developer   ~0054361

The attached .DOCX file is not generated by MantisBT as we generate .DOC files.

There is no problem when using Libre Office, but I am able to reproduce the issue using Microsoft Word 2013

One difference between 1.2.x and 1.3.x is that we longer have the following line in header of the file

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd";>

mboutell

mboutell

2016-11-03 03:16

reporter   ~0054387

So, what should I do ?

mboutell

mboutell

2016-11-23 02:45

reporter   ~0054567

Is there any workaround ?Did you have time to have a look on this issue ?

atrol

atrol

2016-11-23 03:04

developer   ~0054568

Is there any workaround ?

a) Open in Libre Office, store in MS Office Format
b) Try adding the line I mentioned in header of the document 0021798:0054361

Did you have time to have a look on this issue ?

No, you shouldn't expect that I will fix it.
I have hardly any time to work for Mantis at the moment and this issue has no priority for my own usage of Mantis.
The first step would be to check if this is a Mantis or a Microsoft Office issue, which means to read the official format specification.

atrol

atrol

2017-01-02 07:26

developer   ~0054892

@mboutell maybe a workaround that works for you, have a look at 0022103

mboutell

mboutell

2017-01-02 08:29

reporter   ~0054894

@atrol thanks I'm gonna try this !

mboutell

mboutell

2017-01-03 02:38

reporter   ~0054898

@atrol it's perfect it's working thank you !

atrol

atrol

2017-01-31 15:55

developer   ~0055426

PR https://github.com/mantisbt/mantisbt/pull/1013

Related Changesets

MantisBT: master-1.3.x a172cd07

2017-01-31 15:30:57

atrol

Details Diff
Add UTF-8 header to Office Word output

Fixes 0021798
mod - print_all_bug_page_word.php Diff File

MantisBT: master-2.2 17d6796a

2017-01-31 15:30:57

atrol


Committer: dregad Details Diff
Add UTF-8 header to Office Word output

Fixes 0021798

Signed-off-by: Damien Regad <dregad@mantisbt.org>

Cherry-picked from 1.3.x (23da4e0c814e6ed5ee1fc51be6d2b5f15866b7ca)
following incorrect merge conflict resolution in
75ef07835bc3771c9632ed20aa6512ed9d6a17cc.
mod - print_all_bug_page_word.php Diff File

Issue History

Date Modified Username Field Change
2016-10-12 08:44 mboutell New Issue
2016-10-13 03:59 dregad Status new => feedback
2016-10-13 03:59 dregad Note Added: 0054214
2016-10-14 03:53 mboutell File Added: GFS.docx
2016-10-14 03:56 mboutell Note Added: 0054218
2016-10-14 03:56 mboutell Status feedback => new
2016-10-14 04:47 dregad Status new => feedback
2016-10-14 04:47 dregad Note Added: 0054219
2016-10-14 04:55 atrol Note Added: 0054220
2016-10-14 05:03 mboutell Note Added: 0054221
2016-10-14 05:03 mboutell Status feedback => new
2016-10-14 05:14 atrol Status new => feedback
2016-10-14 05:14 atrol Note Added: 0054222
2016-10-14 05:22 mboutell Note Added: 0054223
2016-10-14 05:22 mboutell Status feedback => new
2016-10-14 07:49 atrol Status new => feedback
2016-10-14 07:49 atrol Note Added: 0054224
2016-10-14 07:53 atrol Note Edited: 0054224 View Revisions
2016-10-25 01:25 atrol Assigned To => atrol
2016-10-25 01:25 atrol Status feedback => resolved
2016-10-25 01:25 atrol Resolution open => no change required
2016-10-25 01:25 atrol Note Added: 0054331
2016-10-26 02:38 mboutell Status resolved => feedback
2016-10-26 02:38 mboutell Resolution no change required => reopened
2016-10-26 02:38 mboutell Note Added: 0054346
2016-10-26 02:49 atroladmin Assigned To atrol =>
2016-10-26 02:49 atroladmin Note Added: 0054347
2016-10-26 02:54 mboutell Note Added: 0054348
2016-10-26 02:54 mboutell Status feedback => new
2016-11-01 10:34 atrol Status new => confirmed
2016-11-01 10:34 atrol Note Added: 0054361
2016-11-03 03:16 mboutell Note Added: 0054387
2016-11-23 02:45 mboutell Note Added: 0054567
2016-11-23 03:04 atrol Note Added: 0054568
2017-01-02 07:25 atrol Relationship added has duplicate 0022103
2017-01-02 07:26 atrol Note Added: 0054892
2017-01-02 08:29 mboutell Note Added: 0054894
2017-01-03 02:38 mboutell Note Added: 0054898
2017-01-31 15:50 atrol Assigned To => atrol
2017-01-31 15:50 atrol Status confirmed => assigned
2017-01-31 15:51 atrol Target Version => 1.3.6
2017-01-31 15:55 atrol Note Added: 0055426
2017-02-01 02:24 atrol Changeset attached => MantisBT master-1.3.x a172cd07
2017-02-01 02:24 atrol Status assigned => resolved
2017-02-01 02:24 atrol Fixed in Version => 1.3.6
2017-02-01 22:47 vboctor Status resolved => closed
2017-03-04 06:14 dregad Changeset attached => MantisBT master-2.2 17d6796a
2017-03-08 05:19 atrol Relationship added has duplicate 0022498