View Issue Details

IDProjectCategoryView StatusLast Update
0021710mantisbtuipublic2016-10-02 18:41
ReporterjoelAssigned Todregad 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-beta.3 
Target Version2.0.0-beta.3Fixed in Version2.0.0-beta.3 
Summary0021710: Incorrect display on Bug report confirmation page
Description

As reported in https://github.com/mantisbt/mantisbt/pull/884#issuecomment-248846990

Additional Information

Regression introduced by merge PR https://github.com/mantisbt/mantisbt/pull/884

TagsNo tags attached.

Relationships

related to 0021704 closeddregad Report Stay checkbox shows broken layout on action page 
related to 0021683 closeddregad Standardize "operation successful" messages 

Activities

dregad

dregad

2016-09-22 06:11

developer  

screenshot.png (84,505 bytes)
screenshot.png (84,505 bytes)
dregad

dregad

2016-09-22 07:07

developer   ~0054057

  1. Confirmation message as '0': due to a missing parameter in the html_operation_confirmation() call

  2. Incorrect display of the footer: caused by an extra div tag

  3. 'Report more issues' button: I did not pay attention to the fact that there was an optional 3rd button.

1 & 2 are easily fixed.

The problem with 3 is that the button actually submits a form with the report data, so there are 2 options to address the issue
a) use the API with an encoded URL to submit form data as get parameters
b) revert to hardcoding the confirmation message in bug_report

I'd rather go for a), even if it makes for a long URL string, to avoid code duplication. Let me know your thoughts.

dregad

dregad

2016-09-22 07:20

developer   ~0054058

Last edited: 2016-09-22 07:21

View 2 revisions

@joel Have a look at https://github.com/dregad/mantisbt/tree/f20-21710-oper-success, implements my earlier comments

Note: incidentally, this also fixes 0021704

joel

joel

2016-09-23 03:38

developer   ~0054060

I Checked and tested your recent changes. it fixed the issue both in https://github.com/mantisbt/mantisbt/pull/884#issuecomment-248846990 and 0021704

Thanks

joel

joel

2016-09-23 03:53

developer   ~0054062

@dregad Should i continue merging your fix/changes and push it to my PR?, or you want it to create a new PR with your changes here https://github.com/dregad/mantisbt/tree/f20-21710-oper-success

Let me know your thoughts?

dregad

dregad

2016-09-23 04:02

developer   ~0054063

I'll take care of it, thanks.

dregad

dregad

2016-09-23 04:18

developer   ~0054064

I resolve this issue for the 2 display regressions, will follow up on point 3 in 0021704.

Related Changesets

MantisBT: master 9882d64f

2016-09-22 07:11:06

dregad

Details Diff
Fix bug_report.php regressions

Commit a7ae02dae5e20ba498520551984be026fc658005 (issue 0021683)
introduced 2 regressions when displaying bug report page:

- Confirmation message as '0': due to a missing parameter in the
html_operation_confirmation() call
- Incorrect display of the footer: caused by an extra div tag

Fixes 0021710
mod - bug_report.php Diff File

Issue History

Date Modified Username Field Change
2016-09-22 06:11 dregad New Issue
2016-09-22 06:11 dregad Status new => assigned
2016-09-22 06:11 dregad Assigned To => dregad
2016-09-22 06:11 dregad File Added: screenshot.png
2016-09-22 06:13 dregad Reporter dregad => joel
2016-09-22 06:13 dregad Relationship added related to 0021704
2016-09-22 07:07 dregad Note Added: 0054057
2016-09-22 07:20 dregad Note Added: 0054058
2016-09-22 07:21 dregad Note Edited: 0054058 View Revisions
2016-09-23 03:38 joel Note Added: 0054060
2016-09-23 03:53 joel Note Added: 0054062
2016-09-23 04:02 dregad Relationship added related to 0021683
2016-09-23 04:02 dregad Note Added: 0054063
2016-09-23 04:14 dregad Changeset attached => MantisBT master 9882d64f
2016-09-23 04:14 dregad Status assigned => resolved
2016-09-23 04:14 dregad Resolution open => fixed
2016-09-23 04:14 dregad Fixed in Version => 2.0.0-beta.3
2016-09-23 04:18 dregad Note Added: 0054064
2016-10-02 18:41 vboctor Status resolved => closed