View Issue Details

IDProjectCategoryView StatusLast Update
0021683mantisbtuipublic2016-10-02 18:41
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.0.0-beta.1 
Target Version2.0.0-beta.3Fixed in Version2.0.0-beta.3 
Summary0021683: Standardize "operation successful" messages
Description

We have an API function, html_operation_successful(), which displays a standard confirmation message with a "Proceed" button.

This function is not always used, sometimes we have custom HTML to display the message. In some cases this is required to display a non-standard message or multiple buttons, in others it is really not necessary.

We should offer API functions to avoid use of custom HTML.

TagsNo tags attached.

Relationships

related to 0021109 new Replace "operational successful" pages with flash control 
related to 0021710 closeddregad Incorrect display on Bug report confirmation page 

Activities

Related Changesets

MantisBT: master e6a2378e

2016-09-10 04:54:12

dregad

Details Diff
Use html_operation_successful() instead of custom layout

Fixes 0021683
mod - manage_user_create.php Diff File
mod - manage_user_reset.php Diff File
mod - manage_user_update.php Diff File
mod - query_delete.php Diff File

MantisBT: master d14b3089

2016-09-10 04:57:19

dregad

Details Diff
New html_operation_successful_buttons() function

The new API function expands the existing html_operation_successful(),
allowing display of multiple redirect buttons instead of a single
'Proceed' link.

Fixes 0021683
mod - core/html_api.php Diff File

MantisBT: master 3f610629

2016-09-10 05:04:32

dregad

Details Diff
Use new API for pages with multiple redirection links

- bug_report.php
- news_update.php

Fixes 0021683
mod - bug_report.php Diff File
mod - news_update.php Diff File

MantisBT: master c1359323

2016-09-10 05:32:23

dregad

Details Diff
Remove spacing between the redirection buttons

To be consistent with the rest of the UI where the buttons are printed
right next to each other, remove the   and wrap them in a btn-group
div.

Issue 0021683
mod - core/html_api.php Diff File

MantisBT: master 6d4a5fe2

2016-09-10 05:46:29

dregad

Details Diff
New functions for warning and failure confirmations

Modify html_operation_successful_buttons() to accept an optional type
parameter, allowing caller to specify the type of confirmation message
to display (success, warning, failure).

Add 2 new functions and corresponding language strings:
- html_operation_warning()
- html_operation_failure()

Fixes 0021683
mod - core/html_api.php Diff File
mod - lang/strings_english.txt Diff File

MantisBT: master 750950da

2016-09-10 05:51:26

dregad

Details Diff
Use constants instead of hardcoding values

Define 3 new constants to replace string values:

- 'success' -> CONFIRMATION_TYPE_SUCCESS,
- 'warning' -> CONFIRMATION_TYPE_WARNING,
- 'failure' -> CONFIRMATION_TYPE_FAILURE.

Issue 0021683
mod - core/constant_inc.php Diff File
mod - core/html_api.php Diff File

MantisBT: master 0c00cc9e

2016-09-10 08:24:58

dregad

Details Diff
More replacements of custom layout by html_operation_xxx()

Issue 0021683
mod - core/access_api.php Diff File
mod - lost_pwd.php Diff File

MantisBT: master 49728830

2016-09-10 08:34:43

dregad

Details Diff
Only append default message when none provided

If the caller provided a custom message, then we display it as-is,
without appending the default one based on confirmation type.

This gives more flexibility to the caller when displaying confirmation
messages.

Issue 0021683
mod - core/html_api.php Diff File

MantisBT: master a7ae02da

2016-09-21 03:37:11

dregad

Details Diff
Standardize "operation successful" messages

Adding new API functions to handle display of confirmation messages, and
replace custom HTML in various files to display the same by calls to
these functions.

Fixes 0021683
Merge PR https://github.com/mantisbt/mantisbt/pull/884
mod - bug_report.php Diff File
mod - core/access_api.php Diff File
mod - core/constant_inc.php Diff File
mod - core/html_api.php Diff File
mod - lang/strings_english.txt Diff File
mod - lost_pwd.php Diff File
mod - manage_user_create.php Diff File
mod - manage_user_reset.php Diff File
mod - manage_user_update.php Diff File
mod - news_update.php Diff File
mod - query_delete.php Diff File

MantisBT: master 9882d64f

2016-09-22 07:11:06

dregad

Details Diff
Fix bug_report.php regressions

Commit a7ae02dae5e20ba498520551984be026fc658005 (issue 0021683)
introduced 2 regressions when displaying bug report page:

- Confirmation message as '0': due to a missing parameter in the
html_operation_confirmation() call
- Incorrect display of the footer: caused by an extra div tag

Fixes 0021710
mod - bug_report.php Diff File

Issue History

Date Modified Username Field Change
2016-09-10 05:12 dregad New Issue
2016-09-10 05:12 dregad Status new => assigned
2016-09-10 05:12 dregad Assigned To => dregad
2016-09-10 08:48 dregad Note Added: 0053994
2016-09-10 08:55 atrol Relationship added related to 0021109
2016-09-21 03:39 dregad Changeset attached => MantisBT master e6a2378e
2016-09-21 03:39 dregad Changeset attached => MantisBT master d14b3089
2016-09-21 03:39 dregad Changeset attached => MantisBT master 3f610629
2016-09-21 03:39 dregad Changeset attached => MantisBT master c1359323
2016-09-21 03:39 dregad Changeset attached => MantisBT master 6d4a5fe2
2016-09-21 03:39 dregad Changeset attached => MantisBT master 750950da
2016-09-21 03:39 dregad Changeset attached => MantisBT master 0c00cc9e
2016-09-21 03:39 dregad Changeset attached => MantisBT master 49728830
2016-09-21 03:39 dregad Changeset attached => MantisBT master a7ae02da
2016-09-21 03:39 dregad Status assigned => resolved
2016-09-21 03:39 dregad Resolution open => fixed
2016-09-21 03:39 dregad Fixed in Version => 2.0.0-beta.3
2016-09-23 04:02 dregad Relationship added related to 0021710
2016-09-23 04:14 dregad Changeset attached => MantisBT master 9882d64f
2016-10-02 18:41 vboctor Status resolved => closed