View Issue Details

IDProjectCategoryView StatusLast Update
0021679mantisbttaggingpublic2016-10-02 18:41
ReporteratrolAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-rc.2 
Target Version1.3.2Fixed in Version1.3.2 
Summary0021679: Tagging UI visible without having rights to attach tags
Description

The report issues page allows to attach tags in UI even if the user has no tag_attach_threshold access.
When adding tags, the user get's "Access Denied" after submitting the report.
After that, the issue is created without tags.

TagsNo tags attached.

Relationships

related to 0009450 closedvboctor Tagging possibility directly from "Report Issue" screen 

Activities

Related Changesets

MantisBT: master-1.3.x 7a2ea172

2016-09-08 13:43:33

atrol

Details Diff
Don't show UI to attach tags if user has no access rights for it

Fixes 0021679
mod - bug_report_page.php Diff File

Issue History

Date Modified Username Field Change
2016-09-08 13:20 atrol New Issue
2016-09-08 13:21 atrol Relationship added related to 0009450
2016-09-08 13:34 atrol Assigned To => atrol
2016-09-08 13:34 atrol Status new => assigned
2016-09-08 13:34 atrol Product Version 1.3.1 => 1.3.0-rc.2
2016-09-08 13:34 atrol Target Version => 1.3.2
2016-09-08 13:50 atrol Note Added: 0053982
2016-09-09 08:14 atrol Changeset attached => MantisBT master-1.3.x 7a2ea172
2016-09-09 08:14 atrol Status assigned => resolved
2016-09-09 08:14 atrol Resolution open => fixed
2016-09-09 08:14 atrol Fixed in Version => 1.3.2
2016-10-02 18:41 vboctor Status resolved => closed