View Issue Details

IDProjectCategoryView StatusLast Update
0021659mantisbtcode cleanuppublic2016-10-02 18:41
ReporterJenolanAssigned Tocommunity 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.1 
Target Version1.3.2Fixed in Version1.3.2 
Summary0021659: Syntax error in browser_search_plugin.php
Description

The code tries to send the xml header inline after a php closure which then confuses php as the '<?' starts php looking again.

Line 55 -- ?>
Line 56 -- <?xml version="1.0" encoding="UTF-8" ?>

change to
Line 55 -- echo '<?xml version="1.0" encoding="UTF-8" ?>';
Line 56 -- ?>

TagsNo tags attached.

Relationships

related to 0011964 closeddregad Configuration of Browser Search Plugin 

Activities

Jenolan

Jenolan

2016-09-02 19:52

reporter   ~0053928

Pull request 0000066 on github

atrol

atrol

2016-09-03 03:01

developer   ~0053930

PR is https://github.com/mantisbt/mantisbt/pull/876

Caused by PHP setting short_open_tag
Regression introduced in commit 8e50b7ecf70f0e8683a84f481dbf847366a60920

Related Changesets

MantisBT: master-1.3.x 1b32685b

2016-09-02 19:49:42

Jenolan


Committer: vboctor Details Diff
Issue 0021659 fix for PHP Parse error: syntax error, unexpected 'version' (T_STRING) in browser_search_plugin.php on line 56
mod - browser_search_plugin.php Diff File

Issue History

Date Modified Username Field Change
2016-09-02 19:45 Jenolan New Issue
2016-09-02 19:52 Jenolan Note Added: 0053928
2016-09-03 03:01 atrol Note Added: 0053930
2016-09-03 03:01 atrol Relationship added related to 0011964
2016-09-03 03:02 atrol Status new => acknowledged
2016-09-03 14:53 vboctor Changeset attached => MantisBT master-1.3.x 1b32685b
2016-09-05 14:42 atrol Assigned To => community
2016-09-05 14:42 atrol Status acknowledged => resolved
2016-09-05 14:42 atrol Resolution open => fixed
2016-09-05 14:42 atrol Fixed in Version => 1.3.2
2016-09-05 14:42 atrol Target Version => 1.3.2
2016-10-02 18:41 vboctor Status resolved => closed