View Issue Details

IDProjectCategoryView StatusLast Update
0021304mantisbtadministrationpublic2016-08-28 01:12
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0 
Target Version1.3.1Fixed in Version1.3.1 
Summary0021304: Don't prune system accounts
Description

If a plugin or an administrator creates a system account that may be used to assign issues two or some other purpose, such accounts can be deleted when a user is pruned.

There are several options to consider:

  1. Require such accounts to be marked as protected, and not to prune protected accounts.
  2. Fake a login for such accounts after creating them. This may not work if we decide in the future to provide an option to prune accounts that have no associated data even if they have logged in.
  3. Do more checks to make sure an account is not used, e.g. no issues assigned to them, etc. Same checks that we would want to do when deleting an issue (we don't do that now either). This may not solve the issue, since the service account may not be used yet, but is needed for the future.

I suggest option 1. When 3 is available, we can also make such check.

TagsNo tags attached.

Relationships

related to 0020805 new Protect administrators against deleting users without understanding implications 
related to 0021305 closedvboctor Don't allow deletion of users with associated data 

Activities

Related Changesets

MantisBT: master-1.3.x 8ac7f9c3

2016-08-26 20:14:38

vboctor

Details Diff
Don’t prune protected accounts

Fixes 0021304
mod - manage_user_prune.php Diff File

Issue History

Date Modified Username Field Change
2016-07-16 19:33 vboctor New Issue
2016-07-16 19:38 vboctor Relationship added related to 0021305
2016-07-16 19:43 vboctor Relationship added related to 0020805
2016-08-26 20:15 vboctor Assigned To => vboctor
2016-08-26 20:15 vboctor Status new => assigned
2016-08-26 20:15 vboctor Target Version => 1.3.1
2016-08-26 20:15 vboctor Note Added: 0053897
2016-08-27 18:36 vboctor Changeset attached => MantisBT master-1.3.x 8ac7f9c3
2016-08-27 18:36 vboctor Status assigned => resolved
2016-08-27 18:36 vboctor Resolution open => fixed
2016-08-27 18:36 vboctor Fixed in Version => 1.3.1
2016-08-28 01:12 vboctor Status resolved => closed