View Issue Details

IDProjectCategoryView StatusLast Update
0021171mantisbtuipublic2016-07-09 19:28
ReporteratrolAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-rc.2 
Target Version1.3.0Fixed in Version1.3.0 
Summary0021171: Change look & feel of links, borders and label background
Description

I would like to introduce a few small CSS changes to

  • have some optimizations in look & feel (at least in my opinion)
  • be easily able to distinguish between 1.2.x and 1.3.x when users are posting screen shots

Changes

Links:

  • change and harmonize colors
  • don't display changed link color for visited links
  • don't use text decoration underline for links
  • change color when hovering over links

Borders:

  • change and harmonize colors, only use grey, remove black (to much contrast, stresses eyes)

Background:

  • replace blueish color by another blueish color at various places

Margin:

  • reduced at one place
TagsNo tags attached.

Activities

atrol

atrol

2016-06-29 03:19

developer  

ViewOld.PNG (65,626 bytes)
ViewOld.PNG (65,626 bytes)
atrol

atrol

2016-06-29 03:20

developer  

ViewNew.PNG (64,683 bytes)
ViewNew.PNG (64,683 bytes)
atrol

atrol

2016-06-29 03:29

developer   ~0053480

PR https://github.com/mantisbt/mantisbt/pull/807

vboctor

vboctor

2016-06-29 11:34

manager   ~0053482

I'm not in favor of the following changes:

change and harmonize colors
Not sure what this one means actually.

don't display changed link color for visited links
Why not?

don't use text decoration underline for link
Why not? How do you discover links then? Are you referring to menus and bracket links or also issue content?

replace blueish color by another blueish color at various places
I would rather leave the color that the classic UI has been using for a while. There is no need to introduce a very different color.

atrol

atrol

2016-06-29 16:34

developer   ~0053483

change and harmonize colors
Not sure what this one means actually.
e.g. compare the links in menu and the boxes of "My View" page.
At the moment the link colors are different for visited links.

don't display changed link color for visited links
Why not?
IMO the menu looks quite ugly if some of the entries have been visited and some have not been visited.
If changed colors of visited links are wanted, we should use them for ALL links and introduce this also in modern UI.

don't use text decoration underline for link
Why not? How do you discover links then? Are you referring to menus and bracket links or also issue content?
Why not: Underlined text is not that good to read.
How to discover: I think menu and bracket links are quite easy to discover, all other links can be found quite intuitive as they use the same color.
BTW, modern UI does not underline any link.

replace blueish color by another blueish color at various places
I would rather leave the color that the classic UI has been using for a while. There is no need to introduce a very different color.
I don't think they are very different, but different enough to be easily able to distinguish between 1.2.x and 1.3.x when users are posting screen shots.
We are releasing a new version, so why not change a little bit the look and feel?

vboctor

vboctor

2016-06-30 02:08

manager   ~0053486

OK for the link changes.

As for differentiating the screenshots. How about changing the font to the one used in the modern UI, rather than changing the color?

atrol

atrol

2016-07-01 04:45

developer   ~0053489

How about changing the font
Nice idea, I didn't expect that you would consider bigger changes for this.
They might introduce regressions and might delay getting out 1.3.0.

1.3 is quite conservative in many aspects and still runs using quite old browsers (IE9, ...), so I would not touch 1.3 in such a way.

Changing just the color is certainly much less risk.

Colors can hardly be discussed.
I like the new blueish, maybe just because I see the old one since years and want something fresh.

What about some +1 or -1 from @dregad, @rombert, @cproensa, @syncguru to get a final decision just for the color?

cproensa

cproensa

2016-07-01 07:42

developer   ~0053493

My opinion:
+1 for the color
+1 for the uniformity in color, of clicked/unclicked links, and no underscore
+1 for grey outlines.

i agree on the reasons provided by atrol

dregad

dregad

2016-07-08 04:39

developer   ~0053529

Just noticed that this change introduced a regression in the display of at least the manage tags page (see attached screenshots), did not check all other pages so I'm not sure if there are other side-effects.

Should be fixed prior to release of 1.3.0 final.

dregad

dregad

2016-07-08 04:40

developer  

before-change.png (5,174 bytes)
before-change.png (5,174 bytes)
dregad

dregad

2016-07-08 04:40

developer  

dregad

dregad

2016-07-08 04:40

developer  

dregad

dregad

2016-07-08 04:45

developer   ~0053530

Looking at HTML source, this is caused by an invalid anchor tag. Will commit a fix shortly.

atrol

atrol

2016-07-08 05:26

developer   ~0053531

Will commit a fix shortly
Didn't read, pushed just some moments ago.

dregad

dregad

2016-07-08 06:57

developer   ~0053532

No worries. Just pushed a follow-up fix because using < a name='xxx' > is obsolete.

Related Changesets

MantisBT: master-1.3.x 1612662d

2016-07-05 02:40:29

atrol

Details Diff
Change look & feel of links and borders

Changes
-------

Links:
- set color to blue
- don't display changed link color for visited links
- don't use text decoration underline for links
- change color to red when hovering over links

Borders:
- change and harmonize colors, only use grey, remove black (to much
contrast, stresses eyes)

Margin:
- reduced at one place (looks better at report page)

Fixes 0021171
mod - css/default.css Diff File

MantisBT: master-1.3.x 57d4c7f6

2016-07-08 05:21:31

atrol

Details Diff
Fix invalid anchor

Issue 21171
mod - manage_tags_page.php Diff File

Issue History

Date Modified Username Field Change
2016-06-29 03:19 atrol New Issue
2016-06-29 03:19 atrol Status new => assigned
2016-06-29 03:19 atrol Assigned To => atrol
2016-06-29 03:19 atrol File Added: ViewOld.PNG
2016-06-29 03:20 atrol File Added: ViewNew.PNG
2016-06-29 03:29 atrol Note Added: 0053480
2016-06-29 11:34 vboctor Note Added: 0053482
2016-06-29 16:34 atrol Note Added: 0053483
2016-06-30 02:08 vboctor Note Added: 0053486
2016-07-01 04:45 atrol Note Added: 0053489
2016-07-01 07:42 cproensa Note Added: 0053493
2016-07-05 02:41 atrol Changeset attached => MantisBT master-1.3.x 1612662d
2016-07-05 02:41 atrol Status assigned => resolved
2016-07-05 02:41 atrol Resolution open => fixed
2016-07-05 02:41 atrol Fixed in Version => 1.3.0
2016-07-08 04:39 dregad Status resolved => feedback
2016-07-08 04:39 dregad Resolution fixed => reopened
2016-07-08 04:39 dregad Note Added: 0053529
2016-07-08 04:40 dregad File Added: before-change.png
2016-07-08 04:40 dregad File Added: regression-1-all-labels-blue-even-when-no-links.png
2016-07-08 04:40 dregad File Added: regression-2-labels-without-links-turn-red-on-hover.png
2016-07-08 04:45 dregad Note Added: 0053530
2016-07-08 05:26 atrol Note Added: 0053531
2016-07-08 05:26 atrol Changeset attached => MantisBT master-1.3.x 57d4c7f6
2016-07-08 05:29 atrol Status feedback => resolved
2016-07-08 05:29 atrol Resolution reopened => fixed
2016-07-08 06:57 dregad Note Added: 0053532
2016-07-09 19:28 vboctor Status resolved => closed