View Issue Details

IDProjectCategoryView StatusLast Update
0021140mantisbtdb schemapublic2017-02-17 18:45
ReporteratrolAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version2.0.0-beta.1Fixed in Version2.0.0-beta.1 
Summary0021140: Remove DB2 support
Description

DB2 is deprecated in 1.3 since none of the MantisBT core developers has access to this platform.

TagsNo tags attached.

Relationships

related to 0022400 closeddregad Installer does not show "GOOD" status for DB connections 

Activities

Related Changesets

MantisBT: master 92fd6f64

2016-06-19 10:51:11

atrol

Details Diff
Remove DB2 support

Fixes 0021140
mod - admin/install.php Diff File
mod - config_defaults_inc.php Diff File
mod - core.php Diff File
mod - core/database_api.php Diff File
mod - core/obsolete.php Diff File
mod - docbook/Admin_Guide/en-US/About.xml Diff File
mod - docbook/Admin_Guide/en-US/Installation.xml Diff File
mod - docbook/Admin_Guide/en-US/config/database.xml Diff File

MantisBT: master 42718557

2017-02-17 18:37:06

dregad

Details Diff
Show "GOOD" status for installer DB connect checks

Since removal of DB2 support (see issue 0021140), the installer does
not display "GOOD" status anymore for Admin and User DB connection
checks.

This also improves the logic for the Admin account connection check, we
now capture a "BAD" status if the Admin can connect to the DB, but does
not have access to the database.

Fixes 0022400
mod - admin/install.php Diff File

Issue History

Date Modified Username Field Change
2016-06-19 10:59 atrol New Issue
2016-06-19 10:59 atrol Status new => assigned
2016-06-19 10:59 atrol Assigned To => atrol
2016-06-19 13:16 atrol Note Added: 0053424
2016-06-20 13:42 atrol Changeset attached => MantisBT master 92fd6f64
2016-06-20 13:42 atrol Status assigned => resolved
2016-06-20 13:42 atrol Resolution open => fixed
2016-06-20 13:42 atrol Fixed in Version => 2.0.0-beta.1
2016-07-09 17:50 vboctor Category code cleanup => db schema
2016-07-19 04:19 vboctor Status resolved => closed
2017-02-17 18:26 dregad Relationship added related to 0022400
2017-02-17 18:45 dregad Changeset attached => MantisBT master 42718557