View Issue Details

IDProjectCategoryView StatusLast Update
0021087mantisbtdocumentationpublic2016-06-12 00:42
ReporterdregadAssigned Todregad 
PrioritynormalSeveritytextReproducibilityN/A
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0021087: Document replacement of $g_page_title config by $g_top_include_page
Description

Following removal of $g_page_title config (see 0021086), the documentation was not updated to reflect the change.

TagsNo tags attached.

Relationships

related to 0021086 closeddregad Replacement of $g_page_title config by $g_top_include_page 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master cacac6ac

2016-06-11 10:44:02

dregad

Details Diff
CSS: restore 'pagetitle' class

This reverts commit 24e35d7d106024aa7793bc84ec274fb621d6d2bb.

While not used in the code anymore since removal of html_header()
function (see 6d6f093ea073681a0d6ccf1611e8789dbc84070e), the class is
still referenced in the documentation to be used for custom page title
via $g_top_include_page.

Fixes 0021087
mod - css/default.css Diff File

MantisBT: master 416a26ef

2016-06-11 11:36:05

dregad

Details Diff
New html_print_logo() API function

This makes it easier for people to add the logo in an include file,
since it is not shown anymore when $g_top_include_page is set.

The html_top_banner() function was modified to use the new API.

Fixes 0021087
mod - core/html_api.php Diff File

MantisBT: master ab9db31c

2016-06-11 11:36:49

dregad

Details Diff
Doc: replacement of $g_page_title by $g_top_include_page

Fixes 0021087
mod - docbook/Admin_Guide/en-US/config/display.xml Diff File
mod - docbook/Admin_Guide/en-US/config/html.xml Diff File

Issue History

Date Modified Username Field Change
2016-06-11 11:29 dregad New Issue
2016-06-11 11:29 dregad Status new => assigned
2016-06-11 11:29 dregad Assigned To => dregad
2016-06-11 11:29 dregad Relationship added related to 0021086
2016-06-11 11:44 dregad Changeset attached => MantisBT master cacac6ac
2016-06-11 11:44 dregad Changeset attached => MantisBT master 416a26ef
2016-06-11 11:44 dregad Changeset attached => MantisBT master ab9db31c
2016-06-11 11:44 dregad Status assigned => resolved
2016-06-11 11:44 dregad Resolution open => fixed
2016-06-11 11:44 dregad Fixed in Version => 1.3.0-rc.2
2016-06-12 00:42 vboctor Status resolved => closed