View Issue Details

IDProjectCategoryView StatusLast Update
0020818mantisbtupgradepublic2016-06-12 00:42
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-rc.1 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020818: Upgrade unattended script fails
Description

The upgrade unattended script fails due to access checks, null steps, etc.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 97fd55f5

2016-04-09 00:16:44

vboctor

Details Diff
Remove redundant access check

This access check was causing the upgrade_unattended script to fail.
The check is redundant, since the only product code has ensure access for the
same access level.
mod - core/plugin_api.php Diff File

MantisBT: master b5178344

2016-04-09 00:35:28

vboctor

Details Diff
Include plugin api even in maintenance mode

Otherwise, this fails upgrade unattended.
mod - core.php Diff File

MantisBT: master 72d200fe

2016-04-09 03:21:17

vboctor

Details Diff
Handle null steps in upgrade unattended

Due to recent changes in schema.php, the following step now breaks
unattended upgrade:
$g_upgrade[184] = null;

This change fixes that.
mod - admin/upgrade_unattended.php Diff File

MantisBT: master d4d42571

2016-04-09 03:22:05

vboctor

Details Diff
Access check breaks unattended upgrade

Removed a redundant access check that breaks the unattended upgrade.
mod - core/plugin_api.php Diff File

Issue History

Date Modified Username Field Change
2016-04-17 23:16 vboctor New Issue
2016-04-17 23:16 vboctor Status new => assigned
2016-04-17 23:16 vboctor Assigned To => vboctor
2016-04-17 23:17 vboctor Changeset attached => MantisBT master d4d42571
2016-04-17 23:17 vboctor Changeset attached => MantisBT master 72d200fe
2016-04-17 23:17 vboctor Changeset attached => MantisBT master b5178344
2016-04-17 23:17 vboctor Changeset attached => MantisBT master 97fd55f5
2016-04-17 23:18 vboctor Status assigned => resolved
2016-04-17 23:18 vboctor Resolution open => fixed
2016-04-17 23:18 vboctor Fixed in Version => 1.3.0-rc.2
2016-06-12 00:42 vboctor Status resolved => closed