View Issue Details

IDProjectCategoryView StatusLast Update
0020746mantisbthtmlpublic2016-08-15 09:02
ReportermatthiasbryAssigned Todregad 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.19 
Target Version1.2.20Fixed in Version1.2.20 
Summary0020746: HTML status legend bar does not show dead-end status
Description

In html_status_legend() in core/html_api.php, the code tests for status that are not in the workflow as to not display them when drawing the status legend bar.

However, it only tests for "outbound arrows", (i.e. isset(workflow[status])), making it so that dead-end status, i.e. status who can be attained but not moved out from, are not displayed.

Steps To Reproduce

Go to Administration > Configuration > Workflow and uncheck all boxes in one specific workflow row (or edit config_inc.php accordingly). Go to view_all_bug_page.php or similar and see that the status corresponding to said row is not displayed in the legend.

TagsNo tags attached.

Relationships

duplicate of 0011553 closeddhx Status legend doesn't show final workflow states 

Activities

dregad

dregad

2016-03-23 14:01

developer   ~0052847

This is fixed in version 1.3 see 0011553

atrol

atrol

2016-03-23 14:30

developer   ~0052848

Shouldn't this be fixed in 1.2.1 according 0011553?

dregad

dregad

2016-03-23 19:47

developer   ~0052850

You're right - I only did a search and found the issue, without actually checking that the patch had also been applied to 1.2.x branch, and more importantly, without testing whether the bug was indeed resolved.

I can confirm that the problem persists in 1.3.x.

dregad

dregad

2016-03-23 20:18

developer   ~0052851

PR https://github.com/mantisbt/mantisbt/pull/746

Related Changesets

MantisBT: master-1.2.x 7137b78b

2016-03-23 20:08:26

dregad

Details Diff
Status legend doesn't show final workflow states

The patch for issue 0011553 did not properly fix the problem, as the code
only checked for the workflow allowing to leave a state.

We now also cover the case of entering the state.

Fixes 0020746
mod - core/html_api.php Diff File

MantisBT: master e18a9c23

2016-03-23 20:08:26

dregad

Details Diff
Status legend doesn't show final workflow states

The patch for issue 0011553 did not properly fix the problem, as the code
only checked for the workflow allowing to leave a state.

We now also cover the case of entering the state.

Fixes 0020746
mod - core/html_api.php Diff File

Issue History

Date Modified Username Field Change
2016-03-23 09:49 matthiasbry New Issue
2016-03-23 14:01 dregad Assigned To => dregad
2016-03-23 14:01 dregad Status new => resolved
2016-03-23 14:01 dregad Resolution open => duplicate
2016-03-23 14:01 dregad Note Added: 0052847
2016-03-23 14:01 dregad Relationship added duplicate of 0011553
2016-03-23 14:30 atrol Note Added: 0052848
2016-03-23 19:47 dregad Status resolved => confirmed
2016-03-23 19:47 dregad Resolution duplicate => reopened
2016-03-23 19:47 dregad Note Added: 0052850
2016-03-23 19:48 dregad Assigned To dregad =>
2016-03-23 20:18 dregad Assigned To => dregad
2016-03-23 20:18 dregad Status confirmed => assigned
2016-03-23 20:18 dregad Note Added: 0052851
2016-03-27 07:29 dregad Changeset attached => MantisBT master-1.2.x 7137b78b
2016-03-27 07:29 dregad Status assigned => resolved
2016-03-27 07:29 dregad Fixed in Version => 1.2.20
2016-03-27 07:30 dregad Changeset attached => MantisBT master e18a9c23
2016-03-27 07:30 dregad Target Version => 1.2.20
2016-08-15 09:01 dregad Resolution reopened => fixed
2016-08-15 09:02 dregad Status resolved => closed