View Issue Details

IDProjectCategoryView StatusLast Update
0020679mantisbtfeaturepublic2016-06-12 00:42
Reporterbr8kwallAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.2.19 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020679: Enhance the logging to show email addresses being sent to
Description

Trying to debug email, the event log (plugin) is one of the only logs I can see.

I'm getting "[mail] ERROR: Message could not be sent - Invalid address: 1" in the event log, but I'd really like to be able to see the offending value... in this case the problematic email address I guess.

A note from @vboctor recommended that this be requested as an expansion in mantis logging, versus within the plugin itself.

TagsNo tags attached.

Relationships

related to 0020684 closedvboctor Possible regression caused by changed $g_debug_email handling 

Activities

atrol

atrol

2016-03-10 03:51

developer   ~0052732

this is caused by setting $g_debug_email = ON;
ON is a defined constant value 1 which is treated as the email address
So the logging does what it should.

https://www.mantisbt.org/forums/viewtopic.php?f=3&t=23672#p58948

Behaviour might change in 1.3, see also 0020684

dregad

dregad

2016-03-10 04:27

developer   ~0052734

this is caused by setting $g_debug_email = ON;

I thought about this as a possible cause, but then discarded that because the original report mentioned Product Version 1.2.19.

The change in $g_debug_email handling was only introduced in 1.3.0-beta.1

atrol

atrol

2016-03-10 04:51

developer   ~0052736

The change in $g_debug_email handling was only introduced in 1.3.0-beta.1

Right, but $g_debug_email = ON does also not work in 1.2.19

dregad

dregad

2016-03-10 05:39

developer   ~0052739

Good point. Thanks.

dregad

dregad

2016-06-05 18:58

developer   ~0053269

Following resolution of 0020684, I thought it made sense to improve the logging as suggested here

Related Changesets

MantisBT: master 0bb3cfb1

2016-06-05 18:49:47

dregad

Details Diff
Enhance logging to show debug email when used

Prior to this, when using an invalid address, user would not see a clear
indication in the log file that the debug email was being used,
resulting in confusion caused by the error message generated by
email_send().

This commit adds a LOG_EMAIL_VERBOSE entry clearly showing when the
debug email address is used.

Fixes 0020679
mod - core/email_api.php Diff File

Issue History

Date Modified Username Field Change
2016-03-09 12:42 br8kwall New Issue
2016-03-10 03:51 atrol Assigned To => atrol
2016-03-10 03:51 atrol Status new => resolved
2016-03-10 03:51 atrol Resolution open => no change required
2016-03-10 03:51 atrol Note Added: 0052732
2016-03-10 03:52 atrol Relationship added related to 0020684
2016-03-10 04:27 dregad Note Added: 0052734
2016-03-10 04:51 atrol Note Added: 0052736
2016-03-10 05:39 dregad Note Added: 0052739
2016-03-22 08:20 atrol Status resolved => closed
2016-06-05 18:58 dregad Assigned To atrol => dregad
2016-06-05 18:58 dregad Status closed => feedback
2016-06-05 18:58 dregad Resolution no change required => reopened
2016-06-05 18:58 dregad Note Added: 0053269
2016-06-05 18:58 dregad Changeset attached => MantisBT master 0bb3cfb1
2016-06-05 18:58 dregad Status feedback => resolved
2016-06-05 18:58 dregad Fixed in Version => 1.3.0-rc.2
2016-06-05 18:58 dregad Target Version => 1.3.0-rc.2
2016-06-05 18:59 dregad Resolution reopened => fixed
2016-06-12 00:42 vboctor Status resolved => closed