View Issue Details

IDProjectCategoryView StatusLast Update
0020642mantisbtadministrationpublic2016-06-12 00:42
ReporterdregadAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-rc.2 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020642: Avatar settings should be moved to plugin config page
Description

It does not make sense to keep Avatar settings in config_defaults page, especially plugin-specific ones such as

This should be handled by the plugin(s)

Even the main $g_show_avatar should be removed: plugin installed = avatars enabled, no plugin = OFF

Tagsavatar

Relationships

related to 0013788 closedvboctor Add EVENT_USER_DISPLAY_AVATAR to enable plugins to use LDAP and Social Networks 
related to 0020641 closedvboctor When $g_show_avatar = OFF, no avatar should be displayed 

Activities

vboctor

vboctor

2016-03-01 00:20

manager   ~0052613

There are two configuration options involved:

  • $g_show_avatar
  • $g_show_avatar_threshold

I personally would like to functionally get rid of both. Not just move them around.

If we are to keep them, then I wonder if we should just keep them in core (since they would apply to multiple providers). Core knows about the concept of avatars and whether they are enabled or not, plugins just serve them when asked.

vboctor

vboctor

2016-03-01 00:21

manager   ~0052614

If we keep show_avatar, then we will only understand OFF and ON (or any value that is not OFF). Hence, we would be removing all gravatar specific values from documentation and ignoring them.

dregad

dregad

2016-03-01 02:53

developer   ~0052618

In my incomplete implementation, I had a "base" Avatar plugin (abstract class), upon which all other avatar plugins are based. With this approach, we can ensure consistency between specific plugins since the Base plugin can take care of common options. And the show_avatar on/off is taken care of by whether a plugin is installed.

cproensa

cproensa

2016-03-09 17:28

developer   ~0052715

$g_show_avatar_threshold
i agree with victor, it should stay in core

However, other thing to discuss is if it's really useful.
Where victor argumented in 0020641:0052595 that avatar should maybe be always ON, and i personally disagree, i can see the point of his reasoning with the show-threshold.

vboctor

vboctor

2016-03-10 00:18

manager   ~0052728

PR: https://github.com/mantisbt/mantisbt/pull/734

Related Changesets

MantisBT: master 7c332266

2016-03-10 00:06:26

vboctor


Committer: dregad Details Diff
Move gravatar specific settings out of core config

Remove gravatar specific configs from config_defaults_inc.php

Fixes 0020642
mod - config_defaults_inc.php Diff File
mod - docbook/Admin_Guide/en-US/config/display.xml Diff File
mod - plugins/Gravatar/Gravatar.php Diff File

Issue History

Date Modified Username Field Change
2016-02-28 05:49 dregad New Issue
2016-02-28 05:49 dregad Relationship added related to 0013788
2016-03-01 00:06 vboctor Assigned To => vboctor
2016-03-01 00:06 vboctor Status new => assigned
2016-03-01 00:07 vboctor Relationship added related to 0020641
2016-03-01 00:20 vboctor Note Added: 0052613
2016-03-01 00:21 vboctor Note Added: 0052614
2016-03-01 02:53 dregad Note Added: 0052618
2016-03-07 05:36 dregad Category bugtracker => administration
2016-03-09 17:28 cproensa Note Added: 0052715
2016-03-10 00:18 vboctor Note Added: 0052728
2016-03-11 11:58 dregad Tag Attached: avatar
2016-03-19 18:23 dregad Changeset attached => MantisBT master 7c332266
2016-03-19 18:23 dregad Assigned To vboctor => dregad
2016-03-19 18:23 dregad Status assigned => resolved
2016-03-19 18:23 dregad Resolution open => fixed
2016-03-19 18:23 dregad Fixed in Version => 1.3.0-rc.2
2016-03-19 18:25 dregad Assigned To dregad => vboctor
2016-04-04 11:05 atrol Target Version => 1.3.0-rc.2
2016-06-12 00:42 vboctor Status resolved => closed