View Issue Details

IDProjectCategoryView StatusLast Update
0020641mantisbtuipublic2016-06-12 00:42
ReporterdregadAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-rc.2 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020641: When $g_show_avatar = OFF, no avatar should be displayed
Description

This works fine in bug view page, but the Timeline always shows an anonymous avatar.

Tagsavatar

Relationships

related to 0013788 closedvboctor Add EVENT_USER_DISPLAY_AVATAR to enable plugins to use LDAP and Social Networks 
related to 0020642 closedvboctor Avatar settings should be moved to plugin config page 

Activities

vboctor

vboctor

2016-02-28 14:58

manager   ~0052595

I'm of the opinion that we should always have avatars ON. This is consistent with all modern services and makes our life easier in terms of layouts. The only concern I heard before if users don't want their MantisBT communicating with external services. In that case, they can have avatars ON, gravatar OFF, and possibly some other providers (e.g. file based or LDAP based, upload your photo) to serve these avatars.

To have a good story, I think we should implement another provider to enable users to upload their avatar picture to MantisBT.

dregad

dregad

2016-03-01 02:55

developer   ~0052619

I'm of the opinion that we should always have avatars ON

I disagree. I believe we should provide admin the choice to use them or not, even if personally I like to use them.

To have a good story, I think we should implement another provider to enable
users to upload their avatar picture to MantisBT

This was part of my original roadmap.

gthomas

gthomas

2016-03-03 14:44

reporter   ~0052645

Please make OFF a real OFF: leave out the placeholder image, too (PR 728)!
If I (as an administrator) can turn it off, the default can be ON :)

vboctor

vboctor

2016-03-06 19:36

manager   ~0052688

If we are going to offer the feature of uploading avatars + the gravatar approach, why would it be necessary to turn avatars off. There is no way to do the same in internet services like github, why is it an expectation to be able to do this in MantisBT?

dregad

dregad

2016-03-07 05:35

developer   ~0052691

There is no way to do the same in internet services like github, why is it an expectation to be able to do this in MantisBT?

Because MantisBT is not just an "internet service", but also an intranet application where someone may not want or care about such feature.

We don't even need a config option for that - no Avatar plugin installed = no avatars displayed.

cproensa

cproensa

2016-03-07 17:58

developer   ~0052695

I agree with the issue.
If avatars are disabled, no blank image should be used.
A blank image should be used when (any) avatar plugin is enabled but there is not a specific image for the user.

I think we should implement another provider to enable users to upload their avatar picture to MantisBT

probably a local avatar storage, its a popular request.

vboctor

vboctor

2016-03-08 12:05

manager   ~0052700

OK, I'll think through the approach to support disabling avatars either explicitly or implicitly via having no avatar plugins installed. Will post a info here or a pull request once done.

@cproensa local avatar storage / ldap ones are good candidates. But I was mentioning the upload ones since it allows end users to manage their own avatars rather than their admin or having a dependency on LDAP for example.

cproensa

cproensa

2016-03-09 17:20

developer   ~0052714

I was mentioning the upload ones since it allows end users to manage their own avatars rather than their admin

a local avatar plugin could provide a page to manage user own image, through "my account" page.

cproensa

cproensa

2016-03-09 17:32

developer   ~0052716

and makes our life easier in terms of layouts

A workaround if that is really a problem, is to have a transparent image, as no avatar when th config is OFF.

vboctor

vboctor

2016-03-10 00:18

manager   ~0052729

PR: https://github.com/mantisbt/mantisbt/pull/734

Related Changesets

MantisBT: master a05fca6e

2016-03-09 23:24:01

vboctor


Committer: dregad Details Diff
Don't show avatar when it's off

If avatar is off or user doesn't have access to see it
then don't show an avatar image.

Fixes 0020641
mod - core/classes/Avatar.class.php Diff File
mod - core/classes/TimelineEvent.class.php Diff File
mod - core/print_api.php Diff File

Issue History

Date Modified Username Field Change
2016-02-28 05:45 dregad New Issue
2016-02-28 05:45 dregad Relationship added related to 0013788
2016-02-28 14:58 vboctor Note Added: 0052595
2016-03-01 00:03 vboctor Assigned To => vboctor
2016-03-01 00:03 vboctor Status new => assigned
2016-03-01 00:07 vboctor Relationship added related to 0020642
2016-03-01 02:55 dregad Note Added: 0052619
2016-03-03 14:44 gthomas Note Added: 0052645
2016-03-06 19:36 vboctor Note Added: 0052688
2016-03-07 05:35 dregad Note Added: 0052691
2016-03-07 05:35 dregad Category bugtracker => ui
2016-03-07 17:58 cproensa Note Added: 0052695
2016-03-08 12:05 vboctor Note Added: 0052700
2016-03-09 17:20 cproensa Note Added: 0052714
2016-03-09 17:32 cproensa Note Added: 0052716
2016-03-10 00:18 vboctor Note Added: 0052729
2016-03-11 11:58 dregad Tag Attached: avatar
2016-03-19 18:23 dregad Changeset attached => MantisBT master a05fca6e
2016-03-19 18:23 dregad Assigned To vboctor => dregad
2016-03-19 18:23 dregad Status assigned => resolved
2016-03-19 18:23 dregad Resolution open => fixed
2016-03-19 18:23 dregad Fixed in Version => 1.3.0-rc.2
2016-03-19 18:25 dregad Assigned To dregad => vboctor
2016-06-12 00:42 vboctor Status resolved => closed