View Issue Details

IDProjectCategoryView StatusLast Update
0020553mantisbtinstallationpublic2016-06-12 00:42
ReporterdregadAssigned Todregad 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-rc.2 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020553: Fatal error in admin/index.php
Description

Browsing to admin index page triggers the following error

Fatal error: Call to undefined function installer_db_now() in /home/dregad/dev/mantisbt/admin/schema.php on line 64

Additional Information

This is a regression introduced by MantisBT master 29898e34, the function was moved to install_helper_functions_api.php but the admin/index.php page does not require the API.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 6f20d376

2016-01-30 18:39:33

dregad

Details Diff
Require install helper functions in schema.php

Following 29898e34c1b533df6cb860cd67ccee363ab9bf96 which moved
install_db_now() to install_helper_functions_api.php, admin/index.php is
throwing an error as the function is not defined within schema.php.

We now require the API from within schema.php.

Fixes 0020553
mod - admin/install.php Diff File
mod - admin/schema.php Diff File
mod - admin/upgrade_unattended.php Diff File
mod - login_page.php Diff File

MantisBT: master 5dc82367

2016-01-30 18:49:46

dregad

Details Diff
Partial revert: helper functions are required in install.php

Looks like I removed the require_api() call a bit too fast in
6f20d376d66aeca6abeedcbefe1524c89e1194af.

Issue 0020553
mod - admin/install.php Diff File

Issue History

Date Modified Username Field Change
2016-01-30 18:44 dregad New Issue
2016-01-30 18:44 dregad Status new => assigned
2016-01-30 18:44 dregad Assigned To => dregad
2016-01-30 18:47 dregad Changeset attached => MantisBT master 6f20d376
2016-01-30 18:47 dregad Status assigned => resolved
2016-01-30 18:47 dregad Resolution open => fixed
2016-01-30 18:47 dregad Fixed in Version => 1.3.0-rc.2
2016-01-30 18:51 dregad Changeset attached => MantisBT master 5dc82367
2016-06-12 00:42 vboctor Status resolved => closed