View Issue Details

IDProjectCategoryView StatusLast Update
0020500mantisbtinstallationpublic2016-08-15 09:02
ReporteratrolAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.2.19 
Target Version1.2.20Fixed in Version1.2.20 
Summary0020500: Installation fails in PHP 7 environment
Description

Environment: Windows 10, XAMPP, PHP 7.0.1, FF 43 or Edge

Running admin/install.php fails

German FF delivers
Content-Encoding-Fehler
Die Webseite, die Sie öffnen möchten, kann nicht angezeigt werden, da sie eine ungültige oder unbekannte Form der Kompression verwendet.

Skript is running after setting $g_compress_html = OFF; in config_defaults_inc.php

Changing back to $g_compress_html = ON; after installation does work.

Tagsphp7

Relationships

duplicate of 0020865 closeddregad 'Content Encoding Error' when errors occur before compress handler is started 
related to 0020501 closeddregad Installer throws warning in PHP 7 environment 
related to 0020864 closeddregad "user_pref_get_language()" not defined 
child of 0020499 closeddregad Compatibility with PHP 7 

Activities

dregad

dregad

2016-01-11 07:14

developer   ~0052290

I was not aware that PHP7 introduced issues related to compression.

Could this be due to your XAMPP config already setting compression (http://php.net/manual/en/zlib.configuration.php#ini.zlib.output-compression) ? PHP can't do both ob_gzhandler() and zlib.output_compression. Although this should normally be handled by compress API.

Maybe tracing what's happening compress_handler_is_enabled() function could help understand the problem. Don't have time to test ATM.

atrol

atrol

2016-01-14 02:06

developer   ~0052307

Last edited: 2016-01-14 02:07

View 2 revisions

I was no longer able to reproduce the issue with latest master.
I found that for 0020501 fixed also this issue.

  • function UserPreferences( $p_user_id, $p_project_id ) {
  • function __construct( $p_user_id, $p_project_id ) {

Issue History

Date Modified Username Field Change
2016-01-11 02:42 atrol New Issue
2016-01-11 02:42 atrol Relationship added child of 0020499
2016-01-11 07:14 dregad Note Added: 0052290
2016-01-14 02:06 atrol Note Added: 0052307
2016-01-14 02:07 atrol Note Edited: 0052307 View Revisions
2016-01-14 02:07 atrol Relationship added related to 0020501
2016-01-14 02:08 atrol Assigned To => atrol
2016-01-14 02:08 atrol Status new => resolved
2016-01-14 02:08 atrol Resolution open => fixed
2016-01-14 02:08 atrol Fixed in Version => 1.3.0-rc.2
2016-01-14 02:08 atrol Product Version 1.3.0-rc.2 => 1.2.19
2016-01-14 02:08 atrol Fixed in Version 1.3.0-rc.2 => 1.2.20
2016-01-14 02:08 atrol Target Version => 1.2.20
2016-04-30 13:18 atrol Relationship added related to 0020864
2016-05-01 04:37 dregad Relationship added duplicate of 0020865
2016-05-01 04:39 dregad Tag Attached: php7
2016-08-15 09:02 dregad Status resolved => closed