View Issue Details

IDProjectCategoryView StatusLast Update
0020470mantisbttoolspublic2016-06-12 00:43
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020470: TravisCI docbook broken
Description

When a commit includes docbook changes, the TravisCI build process errors out [1] with an error

$ ./scripts/travis_script.sh
Building DocBook...
Installing Publican...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package publican

The command "./scripts/travis_script.sh" exited with 100.

[1] https://travis-ci.org/mantisbt/mantisbt/jobs/99832145

TagsNo tags attached.

Relationships

related to 0020471 closeddregad Travis builds should always build docbook 

Activities

dregad

dregad

2016-01-02 17:03

developer   ~0052236

Actually I'm not sure this should be on the roadmap/changelog, since this is effectively NOT a MantisBT issue (just a related tool). Same goes for 0020477.

Related Changesets

MantisBT: master af1a7c6f

2015-12-23 07:16:42

dregad

Details Diff
Travis: Use apt add-on to install Publican

The install via sudo apt-get in the travis scripts was not working
properly, causing the Docbook builds to fail.

Fixes 0020470
mod - .travis.yml Diff File
mod - scripts/travis_before_script.sh Diff File
mod - scripts/travis_script.sh Diff File

Issue History

Date Modified Username Field Change
2016-01-02 11:50 dregad New Issue
2016-01-02 11:50 dregad Assigned To => dregad
2016-01-02 11:50 dregad Status new => assigned
2016-01-02 13:19 dregad Changeset attached => MantisBT master af1a7c6f
2016-01-02 13:19 dregad Status assigned => resolved
2016-01-02 13:19 dregad Resolution open => fixed
2016-01-02 13:19 dregad Fixed in Version => 1.3.0-rc.2
2016-01-02 13:24 atrol Target Version => 1.3.0-rc.2
2016-01-02 17:03 dregad Relationship added related to 0020471
2016-01-02 17:03 dregad Note Added: 0052236
2016-06-12 00:43 vboctor Status resolved => closed