View Issue Details

IDProjectCategoryView StatusLast Update
0020426mantisbtadministrationpublic2016-06-12 00:43
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020426: Admin checks detect 'utf8mb4' collation as non-UTF8
Description

When running the admin checks on a DB using the new[1] 'utf8mb4' collation, tables using this character set are detected as not being UTF-8:

Database
Text column name of type varchar(128) on table mantis_api_token_table is is using UTF-8 collation
Text column name of type varchar(128) on table mantis_api_token_table is using utf8mb4_unicode_ci collation where UTF-8 collation is required.

[1] since MySQL 5.5.3 - https://dev.mysql.com/doc/refman/5.5/en/charset-unicode-utf8mb4.html

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 8148a3d8

2015-12-26 19:02:04

dregad

Details Diff
Admin check: fix MySQL UTF-8 collation check

MySQL 5.5.3 introduced the 'utf8mb4' character which allows storage of
up to 4-byte unicode characters (utf8 only allows 3 bytes) [1].

As a consequence, the current check for collation beginning with 'utf8_'
returns false if the collation is utf8mb4.

This adds a new check_api check_is_collation_utf8() function to ensure
consistent checking of collation, and removes the underscore from the
comparison string.

Fixes 0020426

[1] https://dev.mysql.com/doc/refman/5.5/en/charset-unicode-utf8mb4.html
mod - admin/check/check_api.php Diff File
mod - admin/check/check_database_inc.php Diff File

Issue History

Date Modified Username Field Change
2015-12-26 19:01 dregad New Issue
2015-12-26 19:01 dregad Status new => assigned
2015-12-26 19:01 dregad Assigned To => dregad
2016-01-01 18:56 dregad Changeset attached => MantisBT master 8148a3d8
2016-01-01 18:56 dregad Status assigned => resolved
2016-01-01 18:56 dregad Resolution open => fixed
2016-01-01 18:56 dregad Fixed in Version => 1.3.0-rc.2
2016-06-12 00:43 vboctor Status resolved => closed