View Issue Details

IDProjectCategoryView StatusLast Update
0020403mantisbtemailpublic2016-06-12 00:42
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-rc.1 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020403: Email notifications are hard to troubleshoot
Description

It is hard for users to understand email notifications and understand why a specific user is or is not notified. Based on experience from MantisHub, this is the most confusing aspect of MantisBT for administrators.

We have the following efforts to help with that:

  • EventLog plugin
  • LOG_EMAIL and LOG_EMAIL_RECIPIENT

This work should make it easier for users to get what is going on.

  • What are the log events associated with a single request (EventLog plugin).
  • Have a LOG_EMAIL_VERBOSE for verbose internal only events that are just noise for end users.
  • Always log the high level event that is happening (e.g. issue added).
  • Have consistency in the way we format the log events.

The output should look as follows:
[MAIL] Issue 0000031 reported
[RECIPIENT] Issue = 0000031, add administrator (reporter)
[RECIPIENT] Issue = 0000031, add vboctor (handler)
[RECIPIENT] Issue = 0000031, add administrator (based on access level)
[RECIPIENT] Issue = 0000031, add vboctor (based on access level)
[RECIPIENT] Issue = 0000031, add dev1 (based on access level)
[RECIPIENT] Issue = 0000031, add dev2 (based on access level)
[RECIPIENT] Issue = 0000031, drop dev1 (no email address)
[RECIPIENT] Issue = 0000031, drop dev2 (no email address)

As you can see, the user can understand what is in a request, the top level logical action, why users were added / removed from the notify list.

Tagsmantishub

Relationships

related to 0020596 new LOG_EMAIL_VERBOSE should include LOG_EMAIL 

Activities

dregad

dregad

2015-12-20 15:47

developer   ~0052140

Would have been nice to submit a PR for review, prior to pushing to master...

Related Changesets

MantisBT: master 95f947f0

2015-12-19 18:18:39

vboctor

Details Diff
Improve email logging

Fixes 0020403
mod - config_defaults_inc.php Diff File
mod - core/constant_inc.php Diff File
mod - core/email_api.php Diff File
mod - core/email_queue_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/logging.xml Diff File

MantisBT: master 270f47bf

2015-12-20 03:21:02

vboctor

Details Diff
Further email logging improvements (batch 2)

- Include relationship type name rather than code.
- Remove incorrect relationship msgs for issues w/ no relationships.

Fixes 0020403
mod - core/email_api.php Diff File

MantisBT: master e54d31bf

2015-12-20 13:17:42

cproensa


Committer: dregad Details Diff
Add entry in $g_log_levels for LOG_EMAIL_VERBOSE

There were undefined offset system notices due to the missing array
entry.

Regression introduced by 95f947f000bf66348cfef85f72a4f3e0223f1011

Issue 0020403

Signed-off-by: Damien Regad <dregad@mantisbt.org>
mod - core/logging_api.php Diff File

MantisBT: master 6cbcb254

2015-12-20 14:02:55

cproensa


Committer: dregad Details Diff
Fix variable out of scope in email_api

Regression introduced by 95f947f000bf66348cfef85f72a4f3e0223f1011

Issue 0020403

Signed-off-by: Damien Regad <dregad@mantisbt.org>
mod - core/email_api.php Diff File

Issue History

Date Modified Username Field Change
2015-12-19 18:16 vboctor New Issue
2015-12-19 18:16 vboctor Status new => assigned
2015-12-19 18:16 vboctor Assigned To => vboctor
2015-12-19 18:17 vboctor Tag Attached: mantishub
2015-12-19 18:18 vboctor Changeset attached => MantisBT master 95f947f0
2015-12-19 18:18 vboctor Status assigned => resolved
2015-12-19 18:18 vboctor Resolution open => fixed
2015-12-19 18:18 vboctor Fixed in Version => 1.3.0-rc.2
2015-12-20 03:21 vboctor Changeset attached => MantisBT master 270f47bf
2015-12-20 15:41 dregad Changeset attached => MantisBT master 6cbcb254
2015-12-20 15:41 dregad Changeset attached => MantisBT master e54d31bf
2015-12-20 15:47 dregad Note Added: 0052140
2016-02-10 17:31 atrol Relationship added related to 0020596
2016-06-12 00:42 vboctor Status resolved => closed