View Issue Details

IDProjectCategoryView StatusLast Update
0020354mantisbtcode cleanuppublic2016-06-12 00:43
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-rc.2Fixed in Version1.3.0-rc.2 
Summary0020354: Remove useless 'do_nothing' upgrade function
Description

Since commit 061e66b5 (part of 1.3.0-beta.1), an upgrade step can simply be set to NULL to make it a NO-OP.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master a674ea49

2015-12-07 09:33:33

dregad

Details Diff
Remove useless 'do_nothing' install function

Setting upgrade step to NULL does the same thing since commit
061e66b5cfbda95e2ecbe87803c3388b2642cead.

Fixes 0020354
mod - admin/schema.php Diff File
mod - core/install_helper_functions_api.php Diff File

Issue History

Date Modified Username Field Change
2015-12-07 09:32 dregad New Issue
2015-12-07 09:43 dregad Changeset attached => MantisBT master a674ea49
2015-12-07 09:43 dregad Assigned To => dregad
2015-12-07 09:43 dregad Status new => resolved
2015-12-07 09:43 dregad Resolution open => fixed
2015-12-07 09:43 dregad Fixed in Version => 1.3.0-rc.2
2015-12-07 09:48 dregad Product Version => 1.3.0-beta.1
2016-06-12 00:43 vboctor Status resolved => closed