View Issue Details

IDProjectCategoryView StatusLast Update
0020326mantisbtinstallationpublic2015-12-06 02:45
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0020326: PHP notice when converting tokens from php seralized to json
Description

This follows the introduction of json tokens (in commit 9dfc5fb6edb6da1e0324ceac3a27a727f2b23ba7). Depending on how the upgrade is performed, it may happen that the DB contains tokens already in json format.

In such case, depending on error settings, a PHP notice can be shown to the user which is confusing because the upgrade step's status is GOOD and the upgrade completes successfully.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 320fecc5

2015-11-24 17:58:22

dregad

Details Diff
Suppress unserialize() errors when converting tokens to json

install_check_token_serialization() converts existing tokens from php
serialization to json.

It may happen that the DB already contains tokens in json format, in
which case depending on error settings, a PHP notice can be shown to the
user which is confusing because the upgrade step's status is GOOD and
the upgrade completes successfully.

Fixes 0020326
mod - core/install_helper_functions_api.php Diff File

Issue History

Date Modified Username Field Change
2015-11-28 18:52 dregad New Issue
2015-11-28 18:52 dregad Status new => assigned
2015-11-28 18:52 dregad Assigned To => dregad
2015-11-28 20:03 dregad Changeset attached => MantisBT master 320fecc5
2015-11-28 20:03 dregad Status assigned => resolved
2015-11-28 20:03 dregad Resolution open => fixed
2015-11-28 20:03 dregad Fixed in Version => 1.3.0-rc.1
2015-12-06 02:45 vboctor Status resolved => closed