View Issue Details

IDProjectCategoryView StatusLast Update
0020298mantisbttimelinepublic2016-01-19 15:24
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-beta.3 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0020298: some events in timeline appears in reverse order
Description

some events, created simultaneously, are showed in reverse order than they were created. In history they were registered in the right sequence.

The attached example is a bug created, with user assigned at creation time.
The first event in history table is creation, but is showing the assignment first.

TagsNo tags attached.

Activities

cproensa

cproensa

2015-11-19 16:47

developer  

timeline.png (23,087 bytes)
timeline.png (23,087 bytes)
cproensa

cproensa

2015-11-19 16:59

developer   ~0051902

PR
https://github.com/mantisbt/mantisbt/pull/680

Related Changesets

MantisBT: master 2d3da823

2015-11-19 16:49:30

cproensa


Committer: vboctor Details Diff
Fix query order in history get range result

Fixes the query order to be consistent.
When the query is requested as DESC ordered,
some events, created simultaneously, were
showed in reverse order than their creation,
because id field was still being sorted by
default (ASC) order.

Fixes 0020298
mod - core/history_api.php Diff File

Issue History

Date Modified Username Field Change
2015-11-19 16:47 cproensa New Issue
2015-11-19 16:47 cproensa File Added: timeline.png
2015-11-19 16:59 cproensa Note Added: 0051902
2015-11-22 00:57 vboctor Changeset attached => MantisBT master 2d3da823
2015-11-22 00:57 vboctor Assigned To => vboctor
2015-11-22 00:57 vboctor Status new => resolved
2015-11-22 00:57 vboctor Resolution open => fixed
2015-11-22 00:57 vboctor Fixed in Version => 1.3.0-rc.1
2015-11-22 00:59 vboctor Assigned To vboctor => community
2015-11-27 17:21 atrol Target Version => 1.3.0-rc.1
2015-12-06 02:45 vboctor Status resolved => closed
2016-01-19 15:24 atrol Assigned To community => cproensa