View Issue Details

IDProjectCategoryView StatusLast Update
0020286mantisbtjavascriptpublic2016-07-19 04:19
ReporteratrolAssigned Tosyncguru 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.0.0-beta.1Fixed in Version2.0.0-beta.1 
Summary0020286: Missing JavaScript libraries
Description

JavaScript functionality is broken with default installation ($g_cdn_enabled = OFF;)

jquery-1.11.3.min.js and jquery-ui-1.11.4.min.js have to be added to
https://github.com/syncguru/mantisbt/tree/modern-ui-2/javascript

TagsNo tags attached.

Activities

syncguru

syncguru

2015-11-19 00:02

developer   ~0051877

Sounds good @atrol
Will refresh the PR & then post a fix for this.

syncguru

syncguru

2015-11-29 20:11

developer   ~0051969

@atrol The PR is updated with latest merges. One of those covers disabled CDN scenario with the local copy of the following files:

jquery-2.1.4.min.js

jquery-ui-1.11.4.min.css
jquery-ui-1.11.4.min.js

Is there a reason we still want to use the older version of JQuery?

atrol

atrol

2015-11-30 02:13

developer   ~0051971

We should discuss this with other developers.
I see no reason to use the old version, but there might be users that still want to use IE8.

Dont't forget to change "Internet Explorer 6 and above" at [1] if the descision is to use the new version.

[1] https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-single/#admin.install.requirements.client

atrol

atrol

2015-11-30 02:13

developer   ~0051972

Reminder sent to: dregad, rombert, vboctor

Thoughts?

vboctor

vboctor

2015-11-30 02:40

manager   ~0051973

We are about to release 1.3, if someone doesn't want to move to the modern world, they can use that. In the following version with modern UI, we need to modernize our dependencies and stack to be able to innovate.

As for IE 8, Microsoft is dropping its support completely. See the following articles for some details about their support plans:

http://thenextweb.com/microsoft/2014/08/07/microsoft-will-stop-supporting-older-versions-internet-explorer-january-2016/

dregad

dregad

2015-11-30 08:46

developer   ~0051982

For 1.3, we need to keep compatibility with older browsers. Microsoft ending support for IE8 does not necessarily mean that it's no longer used in the field, especially in corporate environments.

I agree with going for latest jQuery versions in 2.x.

syncguru

syncguru

2015-12-01 00:31

developer   ~0051985

Agree - for 1.3 we should not introduce new jquery library ... it is very lightly used by classic UI.
Once we enable modern UI in 2.x, it would be the time to move to latest JQuery

rombert

rombert

2015-12-02 08:16

developer   ~0051996

For 1.3, we need to keep compatibility with older browsers.

+1

Issue History

Date Modified Username Field Change
2015-11-18 06:02 atrol New Issue
2015-11-18 06:02 atrol Status new => assigned
2015-11-18 06:02 atrol Assigned To => syncguru
2015-11-19 00:02 syncguru Note Added: 0051877
2015-11-29 20:11 syncguru Note Added: 0051969
2015-11-30 02:13 atrol Note Added: 0051971
2015-11-30 02:13 atrol Note Added: 0051972
2015-11-30 02:40 vboctor Note Added: 0051973
2015-11-30 08:46 dregad Note Added: 0051982
2015-12-01 00:31 syncguru Note Added: 0051985
2015-12-02 08:16 rombert Note Added: 0051996
2016-07-10 03:58 syncguru Status assigned => resolved
2016-07-10 03:58 syncguru Resolution open => no change required
2016-07-10 06:51 atrol Resolution no change required => fixed
2016-07-10 06:51 atrol Fixed in Version => 2.0.0-beta.1
2016-07-19 04:19 vboctor Status resolved => closed