View Issue Details

IDProjectCategoryView StatusLast Update
0020196mantisbtcustom fieldspublic2015-12-06 02:45
ReportervboctorAssigned Tovboctor 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-beta.3 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0020196: Invalid query on issue update due to custom field
Description

In some corner cases, the customer hits invalid query which is trying to set the custom field string to null. This is caused in the following case:

  • Custom field is visible on update page.
  • Custom field is not required.
  • Custom field is of type list.
  • Custom field doesn't have any value selected.

In this case, the new custom field value evaluated to default value provided by bug_update.php page which is null. The fix is to change it to ''.

Tagsmantishub

Activities

vboctor

vboctor

2015-10-14 11:55

manager   ~0051630

Here is the Pull Request:
https://github.com/mantisbt/mantisbt/pull/657

Related Changesets

MantisBT: master e6873b32

2015-10-14 11:51:40

vboctor

Details Diff
Fix broken issue update page due to custom field

In some corner cases, the customer hits invalid query which is trying to set
the custom field string to null. This is caused in the following case:

- Custom field is visible on update page.
- Custom field is not required.
- Custom field is of type list.
- Custom field doesn't have any value selected.

In this case, the new custom field value evaluated to default value provided by
bug_update.php page which is null. The fix is to change it to ''.

Fixes 0020196
mod - bug_update.php Diff File

Issue History

Date Modified Username Field Change
2015-10-14 11:49 vboctor New Issue
2015-10-14 11:49 vboctor Status new => assigned
2015-10-14 11:49 vboctor Assigned To => vboctor
2015-10-14 11:49 vboctor Tag Attached: mantishub
2015-10-14 11:55 vboctor Note Added: 0051630
2015-10-16 21:46 vboctor Changeset attached => MantisBT master e6873b32
2015-10-16 21:46 vboctor Status assigned => resolved
2015-10-16 21:46 vboctor Resolution open => fixed
2015-10-16 21:46 vboctor Fixed in Version => 1.3.0-rc.1
2015-12-06 02:45 vboctor Status resolved => closed