View Issue Details

IDProjectCategoryView StatusLast Update
0020140mantisbtcustomizationpublic2016-11-27 00:45
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.3 
Target Version1.3.4Fixed in Version1.3.4 
Summary0020140: EVENT_FILTER_COLUMNS should accept objects along/instead classes
Description

a plugin that hooks on EVENT_FILTER_COLUMNS has to return an array of classes that inherit from MantisColumn.

After thinking on the scenario in this request:
https://www.mantisbt.org/bugs/view.php?id=13180#c51538
I feel using only the class name not versatile enough. It wont allow programatically manage this functionality, because there can only be one class defined for each class->column we would want to add to the system.

If EVENT_FILTER_COLUMNS can accept objects (instances of class that extends MantisColumn), plugins can provide objects with different column names and behaviours at runtime.

TagsNo tags attached.

Activities

cproensa

cproensa

2015-09-26 18:17

developer   ~0051539

proposed PR: https://github.com/mantisbt/mantisbt/pull/655

cproensa

cproensa

2016-09-17 07:47

developer   ~0054032

i have updated the PR, to bring this up again.

Related Changesets

MantisBT: master-1.3.x fd1ef148

2015-09-26 18:03:55

cproensa

Details Diff
Accept objects for event EVENT_FILTER_COLUMNS

Fixes: 0020140
mod - core/columns_api.php Diff File

Issue History

Date Modified Username Field Change
2015-09-26 18:03 cproensa New Issue
2015-09-26 18:17 cproensa Note Added: 0051539
2016-09-17 07:47 cproensa Note Added: 0054032
2016-09-17 07:47 cproensa Assigned To => cproensa
2016-09-17 07:47 cproensa Status new => assigned
2016-11-21 06:59 cproensa Changeset attached => MantisBT master-1.3.x fd1ef148
2016-11-21 06:59 cproensa Status assigned => resolved
2016-11-21 06:59 cproensa Resolution open => fixed
2016-11-21 06:59 cproensa Fixed in Version => 1.3.4
2016-11-21 07:01 dregad Target Version => 1.3.4
2016-11-27 00:45 vboctor Status resolved => closed