View Issue Details

IDProjectCategoryView StatusLast Update
0020088mantisbtjavascriptpublic2015-12-06 02:45
ReportercproensaAssigned Todregad 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version1.3.0-beta.3 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0020088: slow hiding of project-selector, filters
Description

Probably due to this change: 0013285 Move script inclusions from HEAD to document footer

the hiding of project selector button, and the expanded filter pane, which takes place in $document.ready(), is loaded from common.js, which now its included at the end of page.

This seems cause, in some cases, a very noticeable lag while the elements are shown, until finally they disappear. This creates a glitch in the visual appearance, and degrades user experience.

Testing from my installed browsers:
Firefox 40.0.3: takes up to some seconds to finally render the page and hide the elements.
Rekonq 2.4.2: takes less than 1s, but still a visible glitch.
Konqueror 4.13.3: no lag
Chromium 44.0.2403.89: no lag
Midori 0.4.3: no lag

TagsNo tags attached.

Relationships

related to 0013285 closedsyncguru Move script inclusions from HEAD to document footer 
related to 0020081 closeddregad Moving JS to bottom is causing 'ReferenceError: jQuery is not defined' errors 

Activities

atrol

atrol

2015-09-09 02:12

developer   ~0051407

Confirmed in general, but was not able to reproduce "up to some seconds".

"Some seconds" might be caused by installed browser plugins.

Related Changesets

MantisBT: master 8d7ea37e

2015-09-11 10:03:14

dregad

Details Diff
Revert move-js-to-footer

This change (see issue 0013282) introduced several regressions.

This reverts commit 2dbc86b10d10495f1312b781fe0a3519a0d7152a, reversing
changes made to aa9b4f8ad7908325633542840805c4c854adb1f1.

Fixes 0020081, 0020088
mod - core/html_api.php Diff File

Issue History

Date Modified Username Field Change
2015-09-08 19:46 cproensa New Issue
2015-09-09 01:57 atrol Relationship added related to 0013285
2015-09-09 02:12 atrol Status new => confirmed
2015-09-09 02:12 atrol Note Added: 0051407
2015-09-09 02:30 atrol Relationship added related to 0020081
2015-09-10 22:26 vboctor Assigned To => syncguru
2015-09-10 22:26 vboctor Status confirmed => assigned
2015-09-11 11:27 dregad Changeset attached => MantisBT master 8d7ea37e
2015-09-11 11:27 dregad Assigned To syncguru => dregad
2015-09-11 11:27 dregad Status assigned => resolved
2015-09-11 11:27 dregad Resolution open => fixed
2015-09-11 11:27 dregad Fixed in Version => 1.3.0-rc.1
2015-09-11 11:30 dregad Target Version => 1.3.0-rc.1
2015-12-06 02:45 vboctor Status resolved => closed