View Issue Details

IDProjectCategoryView StatusLast Update
0020087mantisbtfilterspublic2015-12-06 02:45
ReporteratrolAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-beta.3 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0020087: Filter by "Fixed in Version" throws error
Description

Filter by "Fixed in Version" throws error:

APPLICATION ERROR 26
Data Type mismatch. Enable detailed error messages for further information.

Steps To Reproduce

If logged in, log out from https://www.mantisbt.org/bugs
Open page https://www.mantisbt.org/bugs/view_all_bug_page.php
Click "Fixed in Version:"
Get the error message

Additional Information

Works for other version fields.
Works when logged in.

TagsNo tags attached.

Relationships

related to 0020105 closeddregad Filter by "Match Type" throws error 

Activities

dregad

dregad

2015-09-09 02:50

developer   ~0051413

I can't reproduce this. do you have a specific filter active ?

atrol

atrol

2015-09-09 03:09

developer   ~0051414

Did you exactly follow the steps to reproduce, especially the "log out" step?

dregad

dregad

2015-09-10 10:35

developer   ~0051438

Apologies, I must have messed up my private browser window when doing this test - I can now reproduce the issue as well.

dregad

dregad

2015-09-11 09:35

developer   ~0051450

PR https://github.com/mantisbt/mantisbt/pull/648

Related Changesets

MantisBT: master 22a972a1

2015-09-11 08:46:45

dregad

Details Diff
Fix error when filtering on Fixed in Version

When logged in as anonmyous and trying to filter by 'Fixed in version',
Mantis throws an APPLICATION ERROR 26.

This is because the filter is initialized to default values with
filter_get_default(), which checks the filter's validity using
filter_ensure_valid_filter() where FILTER_PROPERTY_FIXED_IN_VERSION is
expected to have a type 'string' but is initialized using constant
META_FILTER_ANY which is of type 'int'.

filter_ensure_valid_filter() has been modified to set the correct type
for each property that it checks, which should fix the reported issue as
well as other occurences of incorrect data types in saved filters.

Fixes 0020087
mod - core/filter_api.php Diff File

Issue History

Date Modified Username Field Change
2015-09-08 18:58 atrol New Issue
2015-09-09 02:50 dregad Status new => feedback
2015-09-09 02:50 dregad Note Added: 0051413
2015-09-09 03:09 atrol Note Added: 0051414
2015-09-09 03:09 atrol Status feedback => new
2015-09-10 10:35 dregad Status new => confirmed
2015-09-10 10:35 dregad Note Added: 0051438
2015-09-11 09:34 dregad Relationship added related to 0020105
2015-09-11 09:35 dregad Assigned To => dregad
2015-09-11 09:35 dregad Status confirmed => assigned
2015-09-11 09:35 dregad Description Updated View Revisions
2015-09-11 09:35 dregad Note Added: 0051450
2015-10-24 18:26 dregad Changeset attached => MantisBT master 22a972a1
2015-10-24 18:26 dregad Status assigned => resolved
2015-10-24 18:26 dregad Resolution open => fixed
2015-10-24 18:26 dregad Fixed in Version => 1.3.0-rc.1
2015-12-06 02:45 vboctor Status resolved => closed