View Issue Details

IDProjectCategoryView StatusLast Update
0020080mantisbtfilterspublic2015-12-06 02:45
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0020080: AJAX for 'Match type' and 'Highlight changed' filters doesn't work
Description

When filtering issues, clicking on a field triggers an ajax that lets the user edit the filter criteria.

This does not work for 'Match type' and 'Highlight changed (hours)' fields, and view_filters_page.php is loaded instead.

TagsNo tags attached.

Relationships

has duplicate 0017910 closedatrol MatchType / Hightlight changed expands all filter fields. 

Activities

dregad

dregad

2015-09-07 10:15

developer   ~0051383

The 2 anchor tags are missing the 'dynamic-filter-expander' class which enables the javascript.

For some reason when I migrated the commits from PR 81, I added code to link the class to the 'Highlight changed' tag, but commented it out (commit cbe44c0bfc336939ff65dac853f5a282772a88fd).

The 'Match Type' tag never had it since rombert's original commit (6c6c3d721c321e41b568a118b96e70a1728ca692).

dregad

dregad

2015-09-07 11:26

developer   ~0051387

PR https://github.com/mantisbt/mantisbt/pull/640

vboctor

vboctor

2015-09-07 13:04

manager   ~0051388

Changed category to "Filters" since this is likely where people would look if this bug has been already reported.

Related Changesets

MantisBT: master d2d52ad2

2015-09-07 10:10:37

dregad

Details Diff
Enable dynamic filters for 'Match type' and 'Highlight changed'

Add missing 'dynamic-filter-expander' class to enable the AJAX.

Fixes 0020080
mod - core/filter_api.php Diff File

Issue History

Date Modified Username Field Change
2015-09-07 03:50 dregad New Issue
2015-09-07 10:15 dregad Status new => assigned
2015-09-07 10:15 dregad Product Version 1.3.0-beta.3 => 1.3.0-beta.1
2015-09-07 10:15 dregad Note Added: 0051383
2015-09-07 11:26 dregad Note Added: 0051387
2015-09-07 13:04 vboctor Category javascript => filters
2015-09-07 13:04 vboctor Note Added: 0051388
2015-09-07 18:35 dregad Changeset attached => MantisBT master d2d52ad2
2015-09-07 18:35 dregad Assigned To => dregad
2015-09-07 18:35 dregad Status assigned => resolved
2015-09-07 18:35 dregad Resolution open => fixed
2015-09-07 18:35 dregad Fixed in Version => 1.3.0-rc.1
2015-09-08 18:32 atrol Relationship added has duplicate 0017910
2015-12-06 02:45 vboctor Status resolved => closed