View Issue Details

IDProjectCategoryView StatusLast Update
0019945mantisbttimelinepublic2016-08-16 09:24
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.2 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0019945: Timeline should take selected project into consideration
Description

At the moment, the timeline feature takes user access into consideration, but doesn't take the selected project into account when filtering events. Other My View components take into consideration project, so I wonder if we take the project into consideration for timeline as well.

Tagsmantishub

Relationships

related to 0018015 closedvboctor Refactor history_api to build timeline more efficiently 
related to 0021072 closedcproensa Timeline only show issues from current project 
related to 0021146 closedcproensa Can't retrieve history of a bug with history_get_events_array($bug_id) 

Activities

atrol

atrol

2015-07-20 02:31

developer   ~0051094

This works on our own instance currently running 1.3.0-rc1-dev master-5ee4075.
Didn't have a deeper look, maybe a regresssion from 0018015

Related Changesets

MantisBT: master adbd0882

2015-07-20 09:22:32

vboctor

Details Diff
Timeline should honor current project

Fixes 0019945

This fix a regression caused by issue 0018015
mod - core/history_api.php Diff File

MantisBT: master-1.3.x e48e7375

2016-08-05 05:26:36

cproensa


Committer: dregad Details Diff
Revert limit history range to current project

Revert the changes made by Issue 0019945 (commit adbd0882).

The api function history_get_event_from_row should not impose a
limitation for current project queries.

The original timeline issue, which 0019945 was addressing, has now been
resolved in another way, see issue 0021072.

Fixes: 0021146
mod - core/history_api.php Diff File

Issue History

Date Modified Username Field Change
2015-07-19 21:11 vboctor New Issue
2015-07-19 21:11 vboctor Status new => assigned
2015-07-19 21:11 vboctor Assigned To => vboctor
2015-07-19 21:11 vboctor Tag Attached: mantishub
2015-07-20 02:31 atrol Note Added: 0051094
2015-07-20 09:19 vboctor Relationship added related to 0018015
2015-07-20 09:22 vboctor Changeset attached => MantisBT master adbd0882
2015-07-20 09:22 vboctor Status assigned => resolved
2015-07-20 09:22 vboctor Resolution open => fixed
2015-07-20 09:22 vboctor Fixed in Version => 1.3.0-beta.3
2015-07-20 09:23 vboctor Target Version => 1.3.0-beta.3
2015-09-06 17:37 vboctoradmin Status resolved => closed
2016-07-29 18:48 cproensa Relationship added related to 0021072
2016-07-30 20:22 cproensa Relationship added related to 0021146
2016-08-16 09:24 dregad Changeset attached => MantisBT master-1.3.x e48e7375