View Issue Details

IDProjectCategoryView StatusLast Update
0019676mantisbtinstallationpublic2015-09-06 17:37
ReporterdregadAssigned Todregad 
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0019676: PHP notice in installer when system can't connect as admin
Description

When the installer is not able to connect to the database as admin, the DB version check fails because the version cannot be retrieved from the server. This causes display of a PHP notice because $t_version_info is not defined.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 5fea91cc

2015-04-29 07:07:37

dregad

Details Diff
Fix system notice in installer

When the installer is not able to connect to the database as admin, the
DB version check fails because the version cannot be retrieved from the
server. This causes display of a PHP notice. Initializing
$t_version_info fixes this problem.

Additionally, the test result is shown as 'BAD' in this case, which is
not necessarily correct (we just don't know), so we now display
'POSSIBLE PROBLEM' instead.

Fixes 0019676
mod - admin/install.php Diff File

Issue History

Date Modified Username Field Change
2015-04-29 04:13 dregad New Issue
2015-04-29 04:13 dregad Status new => assigned
2015-04-29 04:13 dregad Assigned To => dregad
2015-04-29 08:45 dregad Changeset attached => MantisBT master 5fea91cc
2015-04-29 08:45 dregad Status assigned => resolved
2015-04-29 08:45 dregad Resolution open => fixed
2015-04-29 08:45 dregad Fixed in Version => 1.3.0-beta.3
2015-09-06 17:37 vboctoradmin Status resolved => closed