View Issue Details

IDProjectCategoryView StatusLast Update
0019648mantisbtauthorizationpublic2015-09-06 17:37
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.2 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0019648: Access denied when reporter re-opens an issue
Description

If a reporter was access level REPORTER attempts to re-open a resolved issue, they get access denied.

This happens when:

  • allow_reporter_reopen = ON
  • allow_reporter_close = OFF
  • update_bug_threshold > REPORTER
Tagsmantishub

Relationships

related to 0019271 closedvboctor Reporter can't re-open or close issues even if they have access 
related to 0019649 closedvboctor change_type is set to "close" when re-opening issues 

Activities

dregad

dregad

2015-04-23 02:51

developer   ~0050604

Related to, or regression caused by 0019271 ?

vboctor

vboctor

2015-04-23 09:59

manager   ~0050609

Is is more that 0019271 was a partial fix that didn't fix all cases.

Related Changesets

MantisBT: master f591e7b6

2015-04-23 02:09:05

vboctor

Details Diff
Fix access denied when reporter re-opens issue

Fixes 0019648
Fixes 0019649
mod - bug_change_status_page.php Diff File
mod - bug_update.php Diff File
mod - core/constant_inc.php Diff File
mod - core/html_api.php Diff File

Issue History

Date Modified Username Field Change
2015-04-23 02:05 vboctor New Issue
2015-04-23 02:05 vboctor Status new => assigned
2015-04-23 02:05 vboctor Assigned To => vboctor
2015-04-23 02:51 dregad Note Added: 0050604
2015-04-23 09:57 vboctor Relationship added related to 0019271
2015-04-23 09:59 vboctor Note Added: 0050609
2015-04-23 09:59 vboctor Relationship added related to 0019649
2015-04-25 13:41 vboctor Changeset attached => MantisBT master f591e7b6
2015-04-25 13:41 vboctor Status assigned => resolved
2015-04-25 13:41 vboctor Resolution open => fixed
2015-04-25 13:41 vboctor Fixed in Version => 1.3.0-beta.3
2015-04-28 03:32 vboctor Tag Attached: mantishub
2015-09-06 17:37 vboctoradmin Status resolved => closed