View Issue Details

IDProjectCategoryView StatusLast Update
0019637mantisbtdb oraclepublic2015-09-06 17:37
ReporterdregadAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0019637: Checking for DB field's existence fails on Oracle
Description

This is due to the ADOdb oci8 driver working with uppercase column names, while Mantis uses lowercase.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 7aaabd3a

2014-05-16 19:18:17

dregad

Details Diff
Fix 0019637: oci8 MetaColumns uppercase

db_field_exists() does not work with oci8 due to the driver's use of
uppercase column names.
mod - core/database_api.php Diff File

Issue History

Date Modified Username Field Change
2015-04-18 19:36 dregad New Issue
2015-04-18 19:36 dregad Status new => assigned
2015-04-18 19:36 dregad Assigned To => dregad
2015-04-18 19:44 dregad Changeset attached => MantisBT master 7aaabd3a
2015-04-18 19:44 dregad Status assigned => resolved
2015-04-18 19:44 dregad Resolution open => fixed
2015-04-18 19:44 dregad Fixed in Version => 1.3.0-beta.3
2015-09-06 17:37 vboctoradmin Status resolved => closed