View Issue Details

IDProjectCategoryView StatusLast Update
0019635mantisbtdb mysqlpublic2015-12-06 02:45
ReporterdregadAssigned Todregad 
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-rc.1Fixed in Version1.3.0-rc.1 
Summary0019635: Update ADOdb to 5.20
Description

We are currently using a patched version of ADOdb 5.19.

The submodule must be updated to use an unpatched library prior to 1.3.0rc1. 5.20 should be released shortly.

Additional Information

This is not truly critical because the bug that was impacting us has actually been cherry-picked from upstream, but as a matter of policy we should not release stable Mantis versions with patched libraries as it is causing problems out in the field, e.g. with distro packages.

TagsNo tags attached.

Relationships

related to 0017508 closeddregad No display of ADOdb version on admin page 

Activities

vboctor

vboctor

2015-08-15 01:10

manager   ~0051258

@dregad, any updates on this issue? This seems to be the one that we have least control over for 1.3.

vboctor

vboctor

2015-10-25 01:16

manager   ~0051710

ping :) -- how are we progressing on the adodb issues that are blocking v1.3?

dregad

dregad

2015-10-25 03:51

developer   ~0051711

The library should in theory have all the fixes in its current head, I (re)started testing mantis with it yesterday actually. It's complex and time consuming due to having to do it for multiple DB types.

vboctor

vboctor

2015-10-25 11:18

manager   ~0051718

Good news... hopefully we can get this out of the way soon. Thanks @dregad.

dregad

dregad

2015-11-28 18:23

developer   ~0051965

ADOdb 5.20.0 was released 28-Nov-2015. I'll do one last round of testing before updating master.

Related Changesets

MantisBT: master 7543abe2

2014-07-16 12:08:08

dregad

Details Diff
Fix PHP notice in admin index page

The error is caused by incorrect regex in ADOdb library.
See https://github.com/ADOdb/ADOdb/issues/16

Fix was applied by cherry-picking commit from upstream master branch
https://github.com/ADOdb/ADOdb/commit/701798f02ad2f06f7bba9e3922a2f6a9d8f05918
mod - library/README.libs Diff File
mod - library/adodb Diff File

MantisBT: master 9ba2be61

2015-11-28 18:59:45

dregad

Details Diff
Update ADOdb to 5.20.0

Fixes 0019635
mod - library/README.libs Diff File
mod - library/adodb Diff File

Issue History

Date Modified Username Field Change
2015-04-18 18:51 dregad New Issue
2015-04-18 18:51 dregad Status new => assigned
2015-04-18 18:51 dregad Assigned To => dregad
2015-04-18 18:54 dregad Additional Information Updated View Revisions
2015-04-18 18:55 dregad Changeset attached => MantisBT master 7543abe2
2015-04-18 18:55 dregad Relationship added related to 0017508
2015-08-15 01:10 vboctor Note Added: 0051258
2015-09-06 17:47 vboctoradmin Target Version 1.3.0-beta.3 => 1.3.0-rc.1
2015-10-25 01:16 vboctor Note Added: 0051710
2015-10-25 03:51 dregad Note Added: 0051711
2015-10-25 11:18 vboctor Note Added: 0051718
2015-11-28 18:23 dregad Note Added: 0051965
2015-11-28 20:03 dregad Changeset attached => MantisBT master 9ba2be61
2015-11-28 20:03 dregad Status assigned => resolved
2015-11-28 20:03 dregad Resolution open => fixed
2015-11-28 20:03 dregad Fixed in Version => 1.3.0-rc.1
2015-12-06 02:45 vboctor Status resolved => closed