View Issue Details

IDProjectCategoryView StatusLast Update
0019629mantisbtbugtrackerpublic2015-09-06 17:37
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0019629: Error handler should catch all known PHP error types
Description

Currently, error_handler() doesn't specifically handle E_STRICT, E_RECOVERABLE and E_USER_DEPRECATED, resulting in a default "catch all" error message which may not be the desired behavior.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 7e3e8937

2014-09-16 11:05:24

dregad

Details Diff
Error API: catch all known error types

Our error handler was not specifically dealing with some known error
types, resulting in a default "catch all" error message e.g. for
E_STRICT or E_RECOVERABLE_ERROR.

Now all constants defined in http://php.net/errorfunc.constants at the
time of this writing are handled, while retaining the default case for
future error types.

Fixes 0019629
mod - core/error_api.php Diff File

MantisBT: master b6abfcb1

2014-09-16 11:05:24

dregad

Details Diff
Treat E_RECOVERABLE_ERROR as a fatal error

By default, Mantis will HALT since as per PHP documentation this is
probably a dangerous error that occured without leaving the Engine in an
unstable state.

Issue 0019629
mod - config_defaults_inc.php Diff File

MantisBT: master ba4f40ec

2015-05-17 05:57:54

dregad

Details Diff
Fix broken deprecated error messages

Commit 7e3e8937e28447d02d3cc46dd2187cd016adce25 introduced a regression
by adding a case for E_USER_DEPRECATED, overriding the existing one.
This caused incorrect display of deprecated error messages.

Issue 0019629
mod - core/error_api.php Diff File

Issue History

Date Modified Username Field Change
2015-04-16 19:09 dregad New Issue
2015-04-16 19:09 dregad Status new => assigned
2015-04-16 19:09 dregad Assigned To => dregad
2015-04-16 19:16 dregad Changeset attached => MantisBT master 7e3e8937
2015-04-16 19:16 dregad Changeset attached => MantisBT master b6abfcb1
2015-04-16 19:16 dregad Status assigned => resolved
2015-04-16 19:16 dregad Resolution open => fixed
2015-04-16 19:16 dregad Fixed in Version => 1.3.0-beta.3
2015-05-17 06:11 dregad Changeset attached => MantisBT master ba4f40ec
2015-09-06 17:37 vboctoradmin Status resolved => closed