View Issue Details

IDProjectCategoryView StatusLast Update
0019590mantisbtattachmentspublic2016-07-19 04:19
ReportervboctorAssigned Tosyncguru 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.2 
Target Version2.0.0-beta.1Fixed in Version2.0.0-beta.1 
Summary0019590: Attach via drag-and-drop
Description

Attaching screenshot and files to MantisBT is not streamlined compared to modern web apps. People expect to drag-and-drop their files into the web app or paste the images within the text.

This need has triggered development of the following plugin:
https://github.com/mantisbt-plugins/PastePicture

As an extension to the modern UI work, I would like us to add support for drag and drop for attachments using the following library:
https://github.com/blueimp/jQuery-File-Upload

Using such approach will require us to upload the file to the server before submitting the issue. This will eventually require a schema change when upload method is DATABASE, but we can start by support it for DISK upload method then add the DATABASE once the feature is in.

TagsNo tags attached.

Relationships

has duplicate 0007288 closedatrol Add Functionality to paste a screen shot 
has duplicate 0012012 closedvboctor Plugin DragAndDropFileUploadJavaApplet (and required core changes) 
has duplicate 0010576 closedvboctor File uploads by drag & drop and copy & paste 
related to 0017919 closedsyncguru Modernize Mantis UI 

Activities

syncguru

syncguru

2015-08-15 23:59

developer   ~0051266

This is implemented and is now part of modern-ui pull request.
https://github.com/mantisbt/mantisbt/pull/272

Attached is an animated gif to show the feature in action.

For this implementation,I used dropzone.js instead
https://github.com/blueimp/jQuery-File-Upload which provides much better solution.



dragNdrop.gif (562,638 bytes)
atrol

atrol

2015-08-16 05:05

developer   ~0051268

I assume you mean https://github.com/enyo/dropzone

Nice functionality
Unfortunately it seems to be a one man show, but same applies to jQuery-File-Upload.

vboctor

vboctor

2015-08-16 17:41

manager   ~0051274

The thing I like about this library is that it enabled the functionality without changing the backend code. Not sure if the other libraries offered the same, but it is exciting to have this feature.

atrol

atrol

2015-08-17 08:26

developer   ~0051281

Tried some browsers.
FF 40 and IE 11 work,
Edge on Windows 10 does not work (can't drop, clicking works)

vboctor

vboctor

2015-08-17 11:39

manager   ~0051283

That matches my finding as well. I've only found Edge not fully work. Testing on Chrome/Safari for Mac and Internet Explorer for Windows 10 works.

syncguru

syncguru

2015-08-30 14:02

developer   ~0051330

Looks like Edge does not support drag and drop yet. Need to keep an eye on this issue: https://github.com/enyo/dropzone/issues/1043 [^]

Thread on Edge drag and drop: http://answers.microsoft.com/en-us/windows/forum/windows_10-desktop/cannot-drag-and-drop-into-edge/42dca624-06ff-4da0-a7a2-ce1151bd7db6 [^]

Issue History

Date Modified Username Field Change
2015-04-08 12:01 vboctor New Issue
2015-04-08 12:02 vboctor Status new => acknowledged
2015-04-08 12:02 vboctor Category ui => attachments
2015-04-08 12:07 vboctor Relationship added related to 0017919
2015-04-08 16:00 atrol Relationship added related to 0012012
2015-04-08 16:02 atrol Relationship added related to 0010576
2015-04-08 16:04 atrol Relationship added has duplicate 0007288
2015-08-10 23:59 vboctor Relationship deleted related to 0012012
2015-08-10 23:59 vboctor Relationship added has duplicate 0012012
2015-08-11 00:00 vboctor Assigned To => syncguru
2015-08-11 00:00 vboctor Status acknowledged => assigned
2015-08-15 23:59 syncguru File Added: dragNdrop.gif
2015-08-15 23:59 syncguru Note Added: 0051266
2015-08-16 05:05 atrol Note Added: 0051268
2015-08-16 17:41 vboctor Note Added: 0051274
2015-08-17 08:26 atrol Note Added: 0051281
2015-08-17 11:39 vboctor Note Added: 0051283
2015-08-30 14:02 syncguru Note Added: 0051330
2016-07-10 03:29 vboctor Status assigned => resolved
2016-07-10 03:29 vboctor Resolution open => fixed
2016-07-10 03:29 vboctor Fixed in Version => 2.0.0-beta.1
2016-07-10 03:46 vboctor Relationship deleted related to 0010576
2016-07-10 03:46 vboctor Relationship added has duplicate 0010576
2016-07-10 07:59 atrol Target Version => 2.0.0-beta.1
2016-07-19 04:19 vboctor Status resolved => closed