View Issue Details

IDProjectCategoryView StatusLast Update
0019475mantisbtemailpublic2015-04-28 03:36
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0019475: Administrators should be able to bypass allow_blank_email = OFF
Description

There are cases where administrators don't want to allow users to have blank emails, yet they want to have special user accounts with no email account to avoid building up queues or causing email failures. Examples of this are:

  • anonymous user account.
  • The "community" user that I added to this tracker and similar users that represent a non-registered user or some queue of work.
  • user account used for incoming emails that don't map to a registered user

The code that consumes the email address handles blank emails, so we just need to disable the blocking of blank emails when logged in user is an administrator.

Tagsmantishub

Relationships

related to 0016070 confirmed Delay due to Mantis trying sending emails to non existent address 

Activities

vboctor

vboctor

2015-03-08 00:17

manager   ~0049152

Pull Request:
https://github.com/mantisbt/mantisbt/pull/586

Related Changesets

MantisBT: master 7e1ec631

2015-03-08 00:16:31

vboctor

Details Diff
Allow Admins to bypass blank email check

Fixes 0019475
mod - core/email_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/email.xml Diff File

Issue History

Date Modified Username Field Change
2015-03-08 00:07 vboctor New Issue
2015-03-08 00:07 vboctor Status new => assigned
2015-03-08 00:07 vboctor Assigned To => vboctor
2015-03-08 00:07 vboctor Relationship added related to 0016070
2015-03-08 00:08 vboctor Description Updated View Revisions
2015-03-08 00:17 vboctor Note Added: 0049152
2015-03-10 10:38 vboctor Changeset attached => MantisBT master 7e1ec631
2015-03-10 10:38 vboctor Status assigned => resolved
2015-03-10 10:38 vboctor Resolution open => fixed
2015-03-10 10:38 vboctor Fixed in Version => 1.3.0-beta.2
2015-03-15 19:58 dregad Status resolved => closed
2015-04-28 03:36 vboctor Tag Attached: mantishub