View Issue Details

IDProjectCategoryView StatusLast Update
0019344mantisbtapi soappublic2016-08-15 09:02
Reporterlukas.hubnerAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.19 
Target Version1.2.20Fixed in Version1.2.20 
Summary0019344: Cannot use object of type stdClass as array
Description

In mc_issue_api.php at line 660 there should be $t_project->name instead of $t_project['name']

Steps To Reproduce

Call mc_issue_add with non existing project

$s = new SoapClient( 'http://localhost/mantis/api/soap/mantisconnect.php?wsdl' );

$proj = new StdClass();
$proj->name = 'xxx';
$issue=array( 'project' => $proj, 'summary' => 'soap test', 'description' => 'soap test', 'category' => 'General' );

$s->mc_issue_add( $u, $p, $issue );

TagsNo tags attached.

Activities

dregad

dregad

2015-02-04 09:03

developer   ~0048786

Looks like an artifact leftover from the nusoap days.

Related Changesets

MantisBT: master-1.2.x 3dcac096

2015-02-04 09:05:44

dregad

Details Diff
Fix 0019344: cannot use object of type stdClass as array
mod - api/soap/mc_issue_api.php Diff File

MantisBT: master 3a29ba7d

2015-02-04 09:05:44

dregad

Details Diff
Fix 0019344: cannot use object of type stdClass as array
mod - api/soap/mc_issue_api.php Diff File

MantisBT: master-1.2.x a4480943

2015-02-04 09:09:31

dregad

Details Diff
Issue 0019344: NuSoap compatibility

NuSoap uses arrays, so using the -> operator will trigger a SYSTEM
NOTICE, Error Description: Trying to get property of non-object.

To avoid that, we typecast the array to object.
mod - api/soap/mc_issue_api.php Diff File

Issue History

Date Modified Username Field Change
2015-02-04 04:26 lukas.hubner New Issue
2015-02-04 08:47 dregad Status new => confirmed
2015-02-04 08:55 dregad Steps to Reproduce Updated View Revisions
2015-02-04 09:03 dregad Note Added: 0048786
2015-02-04 09:14 dregad Changeset attached => MantisBT master-1.2.x 3dcac096
2015-02-04 09:14 dregad Changeset attached => MantisBT master-1.2.x a4480943
2015-02-04 09:14 dregad Assigned To => dregad
2015-02-04 09:14 dregad Status confirmed => resolved
2015-02-04 09:14 dregad Resolution open => fixed
2015-02-04 09:14 dregad Fixed in Version => 1.2.20
2015-02-04 09:14 dregad Target Version => 1.2.20
2015-02-04 09:17 dregad Changeset attached => MantisBT master 3a29ba7d
2016-08-15 09:02 dregad Status resolved => closed